AV won't update

Hi all. My CIS AV stopped updating correctly. It says the last update was an hour ago (12:45 Eastern) and ever since it hasn’t changed. When I try manually updating, I get some network activity, Comodo’s servers being contacted (as the Active Connections list shows), then a progress bar, but then:

“Failed to update the virus signature database.
Please check your internet connection and try again later.”

My Internet connection is fine, and I can lookup/submit files through CIS, use other applications like a browser, get to this Comodo forum, etc.

Reboots didn’t help. In fact, one time when I was repeatedly trying manual updates, I saw my first-ever CIS crash, which gave me an Ooops! error box, then froze my system, requiring a hard reboot.

I’m on CIS 3.12.111745.560, virus sig DB version 2721. It’s been running fine until an hour ago.

Can anyone help? Is this a problem on Comodo’s servers, or is it with my copy of CIS?

If it’s my copy of CIS, can I delete the bases.cav file and revert to the one in the “repair” directory, like I did during the 99% CPU fiasco recently? Will that help? I figure it might be a corrupted current bases.cav file… but I’m just guessing.



I did the same fix we all used for the 99% CPU problem a couple weeks ago… I booted into Safe Mode, deleted the bases.cav file in the scanners/ directory, then moved the one from the repair/ directory (dated October 16) into the scanners/ directory, then rebooted, then told Comodo to update the AV database. That took awhile, but worked fine.

CIS is back to normal now. I’m on DB version 2722 now, and am running a full scan right now, and it seems to be working fine. Before this fix, AV scans would freeze the PC.

Did Comodo push out a defective AV definitions update again (2721, as I mentioned above), then quickly fix it with 2722 that I just got after completing my manual fix?

Or, did my 2721 just get corrupted somehow during transit/download to me? Aren’t checksums supposed to prevent that, though?

My problem seems to be solved, but I’d like an answer.

I guess there may have been a temporary problem with the update servers.

Did you submit that error report by the way?