AV not installing with CIS 3.9

Hi guys,
My OS is Windows XP Home Edition SP2 with all available updates. For some strange reason I cannot get SP3 to install on my PC and after four unsuccesful attempts have decided to stay with SP2. I keep my PC security programs up to date and used regularly. My PC was 100% clean when I began to install CIS this afternoon as I scanned it with SAS, Mbam and also A-Squared after the Comodo CRC scan mentioned below.
Since reformatting my PC about three weeks ago I have been using Windows Firewall and Avira AV until Comodo CIS 3.9 was released yesterday. At the time I thought I would just wait for v3.9 and get a 100% clean install. This morning I decided to take the plunge and downloaded a copy from the link on page one of the notification page on these forums to my desktop. I then uninstalled Avira and did a Power Scan with CRC. Then I switched off the Windows Firewall and installed CIS v3.9. I okayed everything except the toolbar and the other two items on that page. I okayed the AV scan and it started but I soon noticed that although the magnifying glass was going round I had Total objects scanned =0, Total threats found = 0, Start = yes, Duration = 0. I also found that the pause and stop buttons weren’t working. I decided to exit and do the scan after install so I exited via the red X and got the message that the scan hadn’t completed and was I sure this machine was clean. I clicked ok and the installation completed. At first it was very slow to load my settings and my sound card was switched off among other things. A quick reboot solved these problems and Although it seems as though the Firewall and Defence+ are working ok I still had no AV. I have tried to update both manually and automatically but just get the message that the “Antivirus Engine is not Initialized”, I went to Misc>About and saw that Product Version was 3.9.81003.507 and Virus Signature Database Version was 0.
I Tried a few things along with another reboot but nothing worked so I decided to uninstall and reinstall CIS 3.9. I came here and downloaded a clean version for this purpose and used the uninstall Comodo feature in the Start>All Programs>Comodo instead of from the Add/Remove programs feature in Control Panel. After a reboot I reinstalled the new download of CIS 3.9 and exactly the same thing has happened. I again came here to write this post and got a popup saying updates were available which I okayed and after the reboot I saw that the version number has changed to 508. This time I also let the non existant AV scan carry on for 20mins before I exited. Can anyone tell me why the AV will not install on my now two downloads. The downloads were both of 72.2MB. I am not new to Comodo I have used it since V2.4 and previous to my reformat had version 3.8 installed. I have SpywareBlaster installed real time as well and use SAS, MBAM and A-Squared+ as on demand scanners none of which were working when I installed CIS 3.9. The first time I installed it completely offline and thinking this was a reason why decided to do the second on while my PC was connected to the internet. I hope that this problem can be resolved quickly as I would like to start using COmodo CIS again.

Something must be corrupt. I would uninstall comodo. Restart and run a full scan with CSC to clean everything up. Then I would run a full scan with Eusing Registy cleaner http://www.eusing.com/free_registry_cleaner/registry_cleaner.htm and clean everything it find. I would again restart and go to start run and type cmd. When the new window opens type “sfc /scannow” with out the quotes. You might need the windows cd so please have it handy. Once that is done restart and run a error check on the C drive or what ever your drive is called. Make sure to check the automatic fix and scan for errors boxes before doing the check. This will take a long time. But once done try reinstalling once more.