AV is again slowing down driver installation [Issue Report]

  1. What you did: Installing drivers/software.
  2. What actually happened or you actually saw: High CPU usage during installation and taking to much time to finish it.
  3. What you expected to happen or see: Smooth and fast installation.
  4. How you tried to fix it & what happened: Disabling AV fixed the issue.
  5. If its an application compatibility problem have you tried the application fixes here?: N/A
  6. Details & exact version of any application (execpt CIS) involved with download link: Pretty much everything, last time it was Dropbox v1.2.30.
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Just install any software, but to notice the issue pick up complex software that take some time to install even in normal environment.
  8. Any other information (eg your guess regarding the cause, with reasons): This happened last year, maybe even sooner. And since this is happening in both CIS 5.5 and CIS 5.8 and disabling AV fixed the issue, the only possible reason for this behavior is AV database.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: N/A
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: N/A
  3. A CIS config report or file: N/A
  4. Crash or freeze dump file: N/A
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version: See bellow.

Your set-up

  1. CIS version, AV database version & configuration used: See bellow.
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
  3. a) Have you imported a config from a previous version of CIS: No.
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No.
  5. Defense+, Sandbox, Firewall & AV security levels: D+= default, Sandbox= default, Firewall = default, AV = default
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7, SP1, x64, UAC off, admin.
  7. Other security and utility software installed: CCleaner.
  8. Virtual machine used (Please do NOT use Virtual box): N/A

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation



How much longer I’ll have to wait for this topic to be moved to appropriate subsection?!

If you took the trouble to actually read you’d notice it has nothing to do with CIS!

Terepin, I suspect that I am seeing the same problem. See https://forums.comodo.com/antivirus-help-cis/cmdagentexe-high-cpu-on-driver-install-t75979.0.html. What do you mean by

it has nothing to do with CIS!
Enjoy, John.

Indeed it is. But this issue occurred at least once before and it was AV database fault. Reasons why I think it applies to this case as well are:

  1. Both CIS 5.5 and CIS 5.8 are “infected” by this issue.
  2. Both were working OK before.
  3. Both started working bad after certain AV database. (And that is the reason why I wrote it has nothing to do with CIS).


Comodo has done great as an antivirus for three years for me - but since 8th August my charting program FTGT see
and Outlook ( running Windows 7)

are running at 1/10 usual speed on FTGT and 1/4 usual speed on Outlook and Browsing.
I am fairly computer literate - have cleaned out temp files , run scans, done defragment, checked with software developers, reinstlled FTGT, done restore to pre- 8th August, tested FTGT on my other computer running Vista Business and had diagnostics done by Dell support on my hardware and had my IT pro’s check my systems.

The only thing that fixes this is switching off the Anitvirus in Comodo.

Ouch - The whole point is to have an Antivirus program !’

Suggestions please.


Link removed.

Since the cis version 5.5 I noticed the same problem as the line 5.8 beta, Windows 7 32 bit SP1, when it detects new hardware and Windows tries to install the drive, lasts forever when antivirus is turned on (set deafult on stateful), once the antivirus is disable everything goes normal. I hope that this problem be solved in the final version of CIS 5.8. Version 5.5 was a disappointment, I did not expect this to happen, and I see that history repeats on cis 5.8 beta

This is till happening. Please, move it to confirmed bugs.

Thank you for your Issue report.

Moved to verified.

Thank you