AV database update time is set on bootup even though databases are not updated

CIS Version: 3.5.54375.427 (32-Bit)
OS: WinXP SP-3
Bug classification: Cosmetic ;D
Reproducible: Easily, happens on each bootup :slight_smile:

My config:
I have disabled automatic updates of the virus database
on the Real-Time Scanning tab (and only there), as I don’t use
the realtime scanner (the realtime scanning slider is set to disabled).
I only use the Anti-Virus as on-demand scanner…

The bug:
What happens is that on OS bootup, the main (“Summary”) screen of
CIS shows that the antivirus databases have just been updated
, i.e.
the time and date of the last update are set to the time when CIS
loads on OS bootup.
This is false :wink: The antivirus databases have in fact
NOT been updated … (which is the expected behavior,
as I have set updating on the realtime tab as disabled, see above).

But the “last updated” time on the summary screen is set anyway on each bootup >:-D

Best regards, raynor

  • BUMP *

Any plans to address this bug in he next update ?

Every bug will be fixed normally so don’t worry. This one should be out in the next release.

Thanks for reporting it :-TU

Xan

Edit: yea i must have searched in the wrong place, since now i search for bug, i got some results, sorry :slight_smile: , also this may have been submitted then, ill look. Edit2 i found one matching at https://forums.comodo.com/anti_virus_bugs/av_database_update_time_is_set_on_bootup_even_though_databases_are_not_updated-t30172.0.html

Hello, i search for bug and bugs, but no luck? your so confident that you dont even have an bug thread hehe, nice, but i found a bug.

I recently installed Comodo internet security version (December 3), and found this bug.

Right after install i was asked to reboot, i did, right after reenter windows xp 32 bit sp3, i tried to open comodo interface, and in the section antivirus update, i found out it said it was last updated like 1 min after reenter windows.
That was strange, since i unplugged my network cable before installing comodo hehe, i then clicked the blue line where the date and time of the update was written, and an popup windows said unable to update, due to no network.

So maybe in the update window, it should say unable to connect to an update server, or something like that ?, and not the date it tried to get updates.

Also, i find it strange, that you must be the only internet security program i have ever tried, that when an update requires an reboot, you dont have an option to reboot? , you can only click ok, then manually reboot :slight_smile: not a big problem, but getting used to have that option hehe.

woot, i found the bug report i was looking for, but i posted similar here :slight_smile: https://forums.comodo.com/empty-t33826.0.html

But i got version released December 3, and it has still not been fixed ??? Remark original post in november, answer over 1 month later ???

And you said dont worry ?, if that small bug, cant be fixed in 2 month, what about the serious matters ? , since that small bug should be done within 10 minutes of programming if ur good (:NRD)

It will report last time it checked and not the last time it actually updated. That is confusing.

Still not fixed in v3.8.64739.471. >:-D >:-D >:-D

Come on guys, this is a confusing cosmetic issue and should be quite
easy to fix.

Best regards,
raynor