AV automatic updates slow computer down drastically

Windows XP Home Edition SP3
Compaq Presario Desktop
AMD Sempron
3200+
1.80GHz 224 MB of RAM
Using CIS 4.1
Virus Signature Database version 5944

I’ve searched the forum for a problem similar to mine but didn’t see much in terms of feedback. My AV updates(automatically) 3-4 times a day, usually taking anywhere from 10-20 minutes and makes my desktop unusable. The computer slows to a crawl and my browser typically crashes(Google Chrome). If I try to navigate to another website other than the one I’m already at, same thing. It slows to a crawl, locks up, and browser crashes.

I have no other problems with AV nor do I have problems with Comodo Firewall. Updates do update successfully. Real time scanner is enabled and is set to stateful. Heuristics is set to low, not scanning anything larger than 20 MB.

Any ideas why? The previous version didn’t do this. I’ve only had this issue since using 4.1

Some users suggested switching to manually updating the AV database. Do you think this would help?

Any and all feedback is welcomed.

Wanted to add I have ADSL connection. An important piece of info(I think, anyway) I forgot to mention is that my local internet provider will be coming out to switch out our modem. Apparently, there have been many problems with this particular modem. Tech guy said I’d be getting a “real modem.”

Would my modem be causing the problem?

I think the problem is having somewhat limited amount of RAM on your computer.

Last year there was a suggestion to exclude c:\pagefile.sys from the AV scanner (assuming you installed Windows on your c partition). Does that work for you?

Following are some general Windows maintenance tips that may help to make Windows and as a side effect the av update go smoother. Don’t expect miracles though.
How are the settings for your pagefile?
Make sure your system partition has at least 20% free space. Defragment your hard drive; download a trial version of Perfect Disk and let it do its magic.
When somebody has some RAM to give away please add it to your system. That will give Windows more breathing space; it will use the hard drive less and that will make it swifter.

Other than that there is very little that be done about it. When it is really bothering try another av program.

The problems with your ADSL modem are not related to the heavy duty update process of the av. When your system is really put to the test it can eventually effect your surfing experience. But if a skilled technician has established that your modem is a factor than the modem is separate and unrelated problem.

We received the new modem shortly after my post, but the computer still crawls when AV is updating. Nothing has changed in terms of that. In fact, it’s taking me forever to type this out.

The tech guy says it probable that I need more memory in order to accommodate Comodo. I had figured memory was the problem. I just wanted to double-check here with Comodo experts.

My stats: When hovering over c partition I see that I have 50.7 GB of free space and total size is 67.4 GB. When right clicking on properties I have 16.7 GB of used space and 50.7 GB of free space. Capacity being 67.4 GB.

Eric, I do have Windows on my C partition. I will try excluding c:\pagefile.sys and see if that helps. I defragged 3 days ago with Wise Disk Cleaner’s defrag option. While I know it’s not the best I really didn’t want to have to download another program with the way this desktop is in general. I’m assuming the trial version of Perfect disk would be better and that it is free? I’d rather just buy more RAM instead of paying for a trial version of anything. Going to go check it out now, though.

Thanks for your suggestions!

Perfect Disk is not a freeware tool but can be tried for 30 days. Let is do a smart defragmentation and then a boot time defragmentation.

I am with the technician that adding some RAM will work. I know from experience that everything will get more responsive.

CIS AV update process is very heavy on CPU and RAM and slow. Running on a low specs device, I am not surprised at the result. You may have to look at other AV solutions that are much more friendly on resources. I don’t thinks that any amount of defraging will have much of effect on that issue.

Cheers

Sounds like a bunch of hooey from Comodo! It does not take a genius programmer to take a couple of simple steps that would make all of us who suffer with older computers happy.

  • First, LET ME STOP the update. Why on earth is there no pause button on the update screen? How about “Update later” or whatever. You have forced me to turn off automatic updates and do it manually after I am done for the day. PITA.

  • Can’t the task be set to a lower priority? Put the task in the background and let it take forever, who cares? I DO care that the computer is completely unusable.

Thanks for maybe listening…

And on the plus side, other than the slow issue, the product is great!

Good if it can be implemented. avast does not offer a pause button either :slight_smile:

I think it should run automatic updates on low priority. Not manual (after all, you’ve started it).
I think avast works this way.