autorun programmes

under msconfig - startup - 7 items are checked

cfp, boc427 and vengine i know these are required to work so checked. (for complete cis there is only cfp, is this correct?)

the other 4 items are igfxtray, hkcmd, igfxpers and ctfmon. what are these items? is it necessary to run them? all are checked.

under taskbar 6 items are there. cis, boclean, vengine, volume, safely remove hardware and on ac power.

dell laptop - win xp sp3 home edition (genuine).


Hey there Naren ;),

(for complete cis there is only cfp, is this correct?)
igfxtray, hkcmd, igfxpers and ctfmon
igfxtray : is part of the Intel graphics driver. I sujest you keep it enabled hkcmd : part of intel hotkeys igfxpers : part of Nvidia drivers ??? ctfmon : part of microsoft office, completely useless IMO but if you find a way of disabling it, let me know :P

So they’re all legit


ok igfxtray should be enabled and ctfmon should be disabled if possible, right??

what about hkcmd and igfxpers?? enabled or disabled??

revouninstaller - autoruns - shows igfxpers is not running - but its checked under msconfig - startup.

Well, if those autoruns are on my pc, I would disable them. But it’s up to you :wink:


ok. so are these default autoruns on win xp. i dont know much about these things. so what according to you are the required autoruns on win xp sp3.

Well, on default XP uses no autorun programs. It uses services, but shall I spare you from that 88)

They are autoruns from your drivers (What are drivers ?) and probably not needed, I sujest you disable them. If you encounter any problem, which I doubt, you can still enable them. (do not delete the entries !)


thanxx buddy. disabled all. no probs. but yes as u said, ctfmon is again there. other than this everythings fine. now there are only cis, boclean and vengine.


No problem, if there is anything else, just ask :wink:


I thought this thread might be talking about the new MS autoruns patch…

But ahh yes, the infamous ctfmon.

I’ve killed it a few times…

In the control panel

“Regional and Language Options”, “Languages” tab, “Text services and input languages” box area, “Details” button, “Advanced Tab”, .
Then check mark “Turn off advanced text service”.

That worked for me last time, although it’s possible there is another step involved if certain other conditions are involved. Good luck.

This is all in XP, I don’t know about Vista.

ctfmon? Never seen that one before but the rest are definitely as you say… you would probably need to have the rest enabled as those are from drivers used for sound/video/etc…