"Automatically start with windows" option keeps unchecked

I have troubles getting CPF to start automatically with windows. The problem is that the option “Automatically start with windows” is not checked and whenever I check it, it gets unchecked when I click OK in Settings dialog.

Any suggestions?

I’m running CPF ver. 3.0.16.295 with Vista.

Close the firewall GUI from the system tray and then start it again using ‘run as administrator’. You will then be able to change settings like this one.

This is an issue I’ve seen a few times with software that is not truly Windows Vista compatible. It should really either pop-up a elevation prompt or tell you that you can’t do it unless you are an admin.

Try running CFP as an administrator. Because I think UAC blocks your changes :SMLR

Ah, I always forget to try to run things as Administrator :frowning:

Problem solved, it works now.

Thanks.

Hi, I just installed V3 however it does not start automatically when I start my PC. I have been to the setting section and ticked the startup check box, however when I return to the settings it has been unchecked. The other 3 check boxes work fine.

Also, how do I configure the firewall to ask for permission every time a new application tries to access the internet?

Thanks :slight_smile:

Are you using Vista? Version 17? There have been similar problem solved by admin login, checking “run as an admin” on the shortcut, and by turning off UAC. Still a work in progress here.
To configure so that new applications ask, try switching to custom policy mode.

Hi, I am running Win XP