Auto update to new version

Just tried this and after downloading all updates and then installing em all seemed ok, rebooted and found that although firewall had updated the tray icon was stuck on “initialising firewall”.
Could not access firewall options at all.
Gave up and removed it.
Tried the download from main firewall page (supposed to be new version), after download it turns out to be old version.


The new version is being uploaded to the site as we speak (or type) and should be added in a few minutes.


Got the new version now, done a clean install but still get the initialise error, after about five minutes waiting for initialise a popup appered with something about fast user switching (don’t use that) and session manager.
This problem occurs every boot.
Appreciate any info.

Hi Leon,

What is your operating system? Assuming it is XP, Please goto Start->Settings->Control Panel->Administrative Tools->Services, and make sure the service called “Terminal Services” is automatic and running.

This is the only cause of this error. It is just a notification. It does not disable anything. CPF is still active and fully functional. But without terminal services running, you wont be able to use XP Fast user switching.


Yep that sorted it, thanks for the info.
Re “Fast User Switching”, i do not use that or the remote desktop etc. so never bothered with running terminal services.
Puzzled why this version of cpf needs terminal services when previous version had no problem with it disabled.

It does not need. This version just informs you about fast user switching disabled. Previous versions just did not have this notification.

Many thanks for the clarification.