auto backup overwrite?

Is there a setting to allow X amount of copies of the same file to be backup on auto, it is looking like comodo overwrites the old file while copying a new new? thanks

is this because I have no macros turned on… date & time macros?

Yes, there is a setting.
Go to backup step 3 and use revision number max, and set it to the maximum number of files you want.