Asus motherboard utility software blocked

A. THE BUG/ISSUE (Varies from issue to issue) [list type=decimal]

  • Can U reproduce the problem & if so how reliably?:
    Yes, it happens on every reboot
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Install CIS
    2:Restart computer
    3:After computer boots up Asus AI Suite II doesn’t start automatically
  • If not obvious, what U expected to happen:
    Asus AI Suite II should start automatically after boot
  • If a software compatibility problem have U tried the conflict FAQ?:
    Checked FAQ, but getting no popup from CIS to file add to trusted not is in unrecognized files list
  • Any software except CIS/OS involved? If so - name, & exact version:
    Malwarebytes Anti-malware 1.75.0.1300 (resident)
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    After computer boots up Asus AI Suite II doesn’t start by itself. I did rating scan and put all files on trusted list (there are few Asus one but not all). Problematic file is EPUHelp.exe
    After a minute or two window pops up saying “Windows cannot access the specified device, path or file. You may not have appropriate permissions to access the item.” and points to file in question “C:\Program Files (x86)\ASUS\AI Suite II\EPU\EPUHelp.exe”
    Also I see under blocked intrusions event “C:\Program Files (x86)\ASUS\AI Suite II\AsRoutineController.exe” create process trying to run EPUHelp.exe and is being blocked (AsRoutineController.exe is among trusted files).
    When I check certificate for this file it says “A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file.” but this is same file that was installed when system was installed and had no problem running on CIS 5 or 6.
    I manually added problem file to trusted list and now works ok. Still there is a point that CIS 6 and 5 did not complain and everything worked out of the box.

B. YOUR SETUP

  • Exact CIS version & configuration:
    CIS 7.0.313494.4115 Proactive security
  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    HIPS - Safe mode, Auto-sandbox - OFF, Firewall - Safe, AV - Stateful
  • Have U made any other changes to the default config? (egs here.):
    HIPS verbose unchecked
  • Have U updated (without uninstall) from a CIS 5/6?:
    No, clean install
  • Have U imported a config from a previous version of CIS:
    No
    [/list][li]OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 Ultimate 64bit, UAC off, admin account
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a) Malwarebytes Anti-malware 1.75.0.1300 (resident)

[attachment deleted by admin]

Thank you for reporting this. Please edit your first post so that it is in the format provided here. Just copy and paste the code. Then replace the question marks with your responses.

I’m sorry, but all of that information is necessary in order for me to forward this to the devs.

Let me know if you have any questions.

Thank you.

Thank you for providing the full format. After reading through your first post it appears to me that this is expected behavior. A file which is not trusted may not be able to perform certain actions. I’m not sure, but I do know that the BB levels were tweaked slightly between V6 and V7. That may explain why it was able to work correctly for V6 but not for V7.

However, I do not think that this should be considered a bug as adding the file to the trusted files list solves this. I will therefore move this report to Resolved.

By the way, so that you do not run into any problems with this file in the future, in order to have Comodo add it to their trusted files list you can submit it through this topic. I would strongly suggest that you do that.

If you have any questions please feel free to ask.

Thank you.