Assistance required - Xbox 360 and Comodo Firewall

Hi Guys, perhaps someone could help me here.
I have a wireless connection and when I try to connect my Xbox 360, it does not even connect to the network. I tried disabling the protection and I can connect just fine. I used to connect just fine before I had to do a clean restore of my OS.

I have manually added the IP in the Xbox and the DNS ips.

I have even reset the default Router settings to see if I messed up something but no luck.

Someone I know suggested it was Comodo Firewall.

Any help would be appreciated.

Note: Ports are stealth via the option of having the network trusted (1st option).
Using CIS 5.8

I’m assuming your in the defense + mode? if so try setting the slider to “clean PC mode” reboot your computer then when you get a request to trust the application give it approval… :-TU

That might help…


You need to have incoming rules for X Box in Global rules.

If you have a block rule in Global rules change this to log.

Then check the firewall logs to see what is being blocked.


Edit Please try here if that does not work.;msg366094#msg366094

I have checked the global rules and it says:
Allow all outgoing requests if the target is in [my network]
Allow all incoming requests if the target is in [my nettwork].

If i disable the WPE protection on the router I can connect just fine.

Running out of ideas here…

Issue is now resolved. Removed CIS, reconfigured Router and Xbox is able to connect. I have then Installed CIS again but this time did not stealth any ports and it works fine.

Moment I stealth ports, same problem again.

Have you tried the second option?

Alert me to incoming connections and make my ports stealth on a per-case basis

This will give you an alert asking if you want to accept an incoming connection.

Hi there HeffeD,

Yes I have tried everything.

Unfortunately my previous post only confirms that connectivity between Xbox and my network (wireless) works until I restart the Xbox.

While running CIS 5.5 no issues were reported between xbox 360 connectivity to my network, CIS 5.8 for some odd reason does affect it.

My Router is a Belkin N+ F5D8635-4v1 model. Firmware tested were both the default 1.00.17 and the latest one 1.00.23

With CIS installed (all default settings including no ports stealth), Xbox will connect to my wireless (Using either WEP or WPA). However the moment I restart the Xbox, I am unable to even connect to the network.

If I turn off the wireless protection, Xbox is able to connect without a problem.

I have tried to set to allow the ip of the xbox in the trusted zones settings and does not work. I have also manually configured the global rules, as well as stealth ports for a trusted zone with no luck.

Uninstalling CIS would not resolve the issue. I would have to reset the router and without CIS installed, my Xbox is able to connect once Router is re-configured.

Tested 6 times.

This means CIS firewall is affecting the Router somehow.

At the moment until someone could figure out exactly what is CIF issue that is preventing the Xbox 360 to connect to the network, I have no choice but to stop using CIS for now.

I will make a video tomorrow how to solve this

OK thanks Valentin, I will give it one more try once you upload the video, although I suspect I have done the steps already.

download from here