Applications hanging up. A solution.


As many of you people might have noticed, programs and applications randomly freeze up and don’t start until some “hocus pocus” remedy has been applied, like starting some random programs/applications or running some troubleshooting widget.

I’ve been trying to systematically find the problem.

And i think i’ve found it.

Or at least it has been 5 days that my system has not hung up or anything else, and if something hung up i’ve found a way to un-hang stuff systematically and in a way that actually makes sense.

The solution?

I’ve bound a macro key to this command:

    <Path>C:\Program Files\Windows Defender\MpCmdRun.exe</Path>
    <Arguments>-Scan -ScanType  1 -SignatureUpdate -MMPC</Arguments>
    <WorkingDirectory>C:\Program Files\Windows Defender\</WorkingDirectory>

Each time a program/application has hung up, i’ve killed the application and run it then tried re-starting the program/application.

Every single time it worked.

So i’ve come to the conclusion that the only explanation is that both the Security Center and Comodo are trying to scan in real time the same file and get conflicted and thusly either give up and hang the program/application or greatly delay the start of the program/application itself, possibly gimping it by locking some key part of it.

Why i did it? I’ve started to notice that often times when a program/application would not start up either when i killed the program/application or a few minutes after that i would see the yellow triangle. I don’t see MpCmdRun being called each time, but that’s probably because it’s part of a service. Just like i don’t usually see comodo calling its scanner each time i run something. It gets lost in the large amount of stuff that gets called in each second, and the only way is to start actively monitoring the security center and comodo.

Hmmm. I have the issue, but have Win Defender not running via group policy. So I don’t have MpCmdRun in the task manager. I do have MSASCuiL running, which seems to do so even when you are blocking MS Defender via group policy. Not sure if that is an issue or not.

My workaround, as another user pointed out, was to use the 32bit version of the applicaiton (in my case Libre office).

You should turn off Windows defender periodic scanning as it is not necessary to have WD scanning files if you have the AV of CIS installed.

Actually, since windows defender flags me if i don’t run the scan and Comodo has been redesigned for quite some time to accomodate windows defender… I’d like not to have the yellow triangle so that if there is a problem i can visually spot it easily rather than waiting to check on the security center if the triangle means something different than “defender is not active anymore!”

I find Defender to be a bit heavy, which is why I have disabled it via Group Policy registry tweak.

What yellow triangle? It should not be that way if you have the full CIS suite installed as the AV will replace windows defender.

?! it does not look like that at all for me.

Also i clearly saw a notice where CIS said an update would be needed as Defender could not be excluded anymore in the home version.

Then you should perform a clean uninstall and install following this guide.

Okay. i disabled Windows defender and then re-enabled it.

It now displays what you show and recognizes that i have an external AV.

so… yesterday it worked. Tonight the latest update installed. It forces windows defender on, even if i turn it off it either switches itself back on in a few hours or it shows the red cross and switches itself back on in the next reboot even with comodo installed.

uh… to continue my messages on the now locked forum thread… i cannot seem to understand why Windows Firewall and Windows Defender get turned on by themselves at reboot and they are flagged with a red cross if turned off even when comodo is recognised by windows.

So lastnight my other PC got updated to the lastest CFW release. Soon after the update, I started having issues with Libre Office. That must have been why I was having issues on one computer, but not the other. The other computer was running the “released” version of CFW, not the beta. Whatever is causing these programs to hang, must have been introduced recently.

Anyway, I uninstalled 64bit Libre, and reinstalled the 32bit version and that seems to remedy my issues.

personally i’m not having problems ever since i’ve started to run the windows defender quickscan a few minutes after boot up.

thanks for moving the topic.