application rules not followed on a non-C system

A. The bug/issue

  1. What you did: happens on my system WinXP SP3 installed on disk D:, installed GOM Media Player, started the player, it tried to connect to the internet, Comodo Firewall asked if it should allow the connection, I set it as allowed application and ticked the box to remember it
  2. What actually happened or you actually saw: firewall asked again if it should allow the connection and did not allow it, even if the application rule was listed as C:\2Progra~1\GomPlayer\Gom.exe
  3. What you expected to happen or see: No popups, connection allowed
  4. How you tried to fix it & what happened: repeated filling-in the popup again, firewall adds another line of “allow all connections” to the application rule, but the application is still blocked and pop-ups asking what to do keep appearing; added a “manual” application rule, listed as D:\Program Files\GomPlayer\Gom.exe, same behavior; several reboots; re-installation of the player; upgrade to newer version
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): GOM Media Player V 2.1.43 (Welcome GOM Player users - CNET Download)
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: when starting the GOM player, the application rule is never followed
  8. Any other information (eg your guess regarding the cause, with reasons): happens also for older versions for GOM Player and CIS, for application GrLauncher.exe in the same directory, and “some” other applications, but I did not find any “rule” as to which application behaved in this way, is definitely connected with the system being installed on disk D:, my C: system has never had such problems

B. Files appended. (Please zip unless screenshots).

  1. Screenshots of the Defense plus Active Processes List (Required for all issues): Appended
  2. Screenshots illustrating the bug: Not appended
  3. Screenshots of related CIS event logs: Not Appended
  4. A CIS config report or file. Not appended.
  5. Crash or freeze dump file: Not appended
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version. Not appended.

C. Your set-up

  1. CIS version, AV database version & configuration used: 5.10.228257.2253, no AV, FireWall Config
  2. a) Have you updated (without uninstall) from a previous version of CIS: Yes
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: No
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: D+=Not Active, Sandbox=Not Active, Firewall=Safe (also for Clean PC, Learning regime)
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP, SP3, 32 bit, No Uac, Admin
  7. Other security and utility software currently installed: CAS only
  8. Other security software previously installed at any time since Windows was last installed: not sure, but probably none
  9. Virtual machine used (Please do NOT use Virtual box):]

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post

  • C.1 CIS configuration, AV database version, if appropriate
  • C.4 Presumably AV module is off too?

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


PM sent

The required items are:

C.1: CIS configuration Firewall Security (I hope this is what your are looking for)
C.4: antivirus off, so I guess there is no database version

Thank you for looking into this problem.

(My apologies for delay in forwardng this, have been hard at work on Beta review)

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again