Application Control Problem - Unknown / Blank Entries [Resolved]

I’ve tried uninstalling-reinstalling Comodo Firewall 3 times so far but still getting this problem:

The 20th entry into Application Control Rules appear as Unknown or Blank. As a result Comodo can’t “remember” whatever rules are added thereafter, so it’s always asking for my permission when those failed-to-get-added applications needs to call-out.

Any advice appreciated & Thanks,

Windows XP SP2, Avira Antivir PE Classic, Spyware Terminator
Other Apps “on demand”: a-squared Free, SUPERAntiSpyware Free, RKUnhooker, Sandboxie, PowerShadow

Edit: Resolved on 02 April 2007

Sometimes new rules are added successfully, but the 19th rule (in alphabetical order) in the Rules table gets overwritten.

This looks to be a bug (or malware :o). It’s best to contact official support: and to link them to this thread for reference.

When you installed CFP, were the other security programs disabled to avoid potential conflicts?

Each time before I install Comodo:

  • Avira’s guard de-activated (no “Exit” option)
  • Spyware Terminator’s realtime shield disabled (“Exit” causes cpu usage problems currently)

Previously after un-installing Comodo, I:

  • Deleted Comodo folders in “Program Files” and “Documents & Settings”
  • Cleaned registry using CCleaner
  • Also tried uninstalling Comodo drivers in Device Manager under “Non-Plug & Play Drivers”

Atm I’ve un-installed Comodo, and got some Qs before I try again:

  1. Can Comodo be installed in Safe Mode?
  2. HKEY_LOCAL MACHINE\SYSTEM\SOFTWARE[u]COMODO[/u] ← I only just noticed this entry which CCleaner didn’t remove. Wasn’t allowed to delete manually using “regedit”. Finally removed using RegSeeker ← Any idea if it’s normal or “corrupted” behavior for this registry entry?

Much Thanks,

P.S. Hi again, Soya!!

Hi yeow (:WAV)

  1. Yes
  2. This may or may not be obvious, but if a registry key was already deleted while regedit was opened at that spot, it will give an error message. When encountering legacy keys, right-click on them to access full permissions and then the ability to delete them is opened.

Ahhh, finally Comodo FW is working properly again! :BNC So it’s either Safe Mode install or deleting the registry entry that did the trick.

Thanks again Soya, for your input.(:WAV)


Wow! That actually worked? ;D

If you ever need to open this thread just PM me \ any mod.