application agent

hello there all I am a new user and as of now been impressed with COMODO.but I keep getting
a RED circle with diagonal not sure if spelled right,informing me that APPLICATION AGENT is not running is this anything that i should be worried about and how do I make it dissappear ???.regards LANKY10

Hey LANKY10, welcome to the forums :slight_smile:

Here are 2 ways to try and fix this problem:

  1. On the Start Menu, click Run, type in services.msc and make sure that the COMODO Internet Security Helper Service is set to Automatic. If it isn’t, set it to Automatic and reboot.

  2. Run the Diagnostics feature in CIS (Miscellaneous → Diagnostics) - use if first method does not work, or if the COMODO Internet Security Helper Service is already set to Automatic.

Please post back here with results.

Hope this helps :slight_smile:

???hi beanie thanks for reply have tried RUN-SERVICES MISC and DIAGNOSTICS but still no joy.but after re-booting pc the(APP AGENT) now seems to be running again and looks to be working again ;D. thanks again for your help. LANKY10.

Ok, glad to hear your problem is solved :slight_smile:

hello beanie re- my original post for application agent as I said in my reply to you that all at once all started working properly but woudn’t you know it back it came with the same problem,do you have anymore tips to try many regards LANKIE 10 ???


You could try a complete uninstall and reinstall, using the following method:

Guide starts now

Exit CIS by right clicking tray icon, and clicking ‘Exit’ → Click ‘Yes’ at the prompt.

Uninstall CIS using Revo Uninstaller and use the ‘Advanced’ uninstallation method. Let the uninstaller run.

If the uninstaller prompts you for a reboot, click ‘No’.

Click ‘Next’. Delete any remaining Comodo-related registry entries and files found by Revo.

Reboot (very important!)

Download the CIS Cleanup Batch File and run it.


Clean your system of temp/junk files with a program like CCleaner.

Guide ends now

Hope this helps :slight_smile: