Application Agent Not Running [Solved]

Hey guys,

When I turned my computer on this morning, I was greeted by the message: COMODO Application Agent Not Running. When I click on DIAGNOSTICS it reads: The diagnostics utility did not find any problems with your installation. When I click on SCAN or UPDATE VIRUS DATABASE it reads: Error Code 0x800705aa. Insufficient system resources exist to complete the requested service.

Operating System: Windows XP w/ SP3.
Other Security Software: Just CCleaner and Comodo Registry Cleaner.

What I’ve tried:

  • system reboot
  • cleared temp files, etc…
  • complete uninstall
  • complete reinstall
  • ran Comodo Registry Cleaner (just in case)
  • another reboot
  • observed Task Manager

Yet the problem persists. I read through the other posts and tried what was mentioned in them, but nothing works.

I’m not sure why this happened, but I have an idea… could this have something to do with permissions? The reason why I ask is because there is no other logical explanation as to why this would happen.

Thanks guys, I hope an answer comes soon!

Oh, one more question… if the Comodo Application Agent is NOT running, am I at risk? The firewall and anti virus still give me messages, etc… so I am assuming they’re working.

Thanks again,

Paradiseyes

Hello? ???

Does anybody have any ideas?

What I’m most concerned with is what this COMODO agent does and if I can live without it. My fire wall and anti virus seems to be working… I’m confused.

Yes, you may be at risk.
It is possible Application Agent has crashed.
Which version are you using?
Did you do a clean install or an upgrade (and if an upgrade, what version did you upgrade from)?
I don’t know the order you chose to make your attempts, but I would have

  1. (download and save the latest version to the HDD first),
  2. uninstall CIS,
  3. run a registry cleaner to be sure it was fully removed,
  4. reboot,
  5. install with the version just downloaded,
  6. reboot again.
    (This has worked for me).

Also,
If You CANNOT Remove CIS Try Installing The Latest Version (Download > Install)

CG

Thanks for all your help guys.

But I managed to solve the problem myself. I’ll post the answer, just in case anyone else ever has the similar problem. Comodo has always worked great for me, which is why I was a little suspicious when the agent stopped working. After reinstalling it, etc… I still had the same problem. Turns out, the issue was being caused by a windows permission error. Then I recalled why…

I had reinstalled the newest update for iTunes, which was corrupt and it totally messed up my iTunes library. I had to uninstall the program manually, which involved a treacherous journey into the registry. By accident, I must have deleted a key associated with permissions for those particular programs. How… who knows?

But I managed to fix this problem by replacing the key and then resetting the permissions for my account while in safe mode. To be honest, I didn’t think it would work but it did and my Comodo (along with a couple other programs) is working perfectly fine now!!! [knocks on wood]

So again, thanks for your help guys. Next time anyone has problems like this, and you were venturing into the registry (which I recommend to NEVER do unless you know what you’re doing) then double check that your permissions are in order.

I’m just glad that everything is fixed.

(L)

  • Thread Will Be Closed -
    Reason: Issue Solved
    To Unlock: PM A Moderator

CG