"Appguard.dll is not a valid windows image"

That’s what my browser says when I fire it up. (firefox 2) and then it won’t connect to the
internet. “Appguard.dll is not a valid windows image” it says, “Please check this against your
application disk.”
So I tried uninstalling Comodo Firewall and turning off Kaspersky and that didn’t work either.
I am on a wireless connection and when I check it, it says it is connected and has sent
x number of packets. But it hasn’t recieved any. Browser says it can’t find server.
I am writing this because I hooked up a different computer which doesn’t have Comodo installed
so I could get on the internet. But would prefer to use the other computer as it has all my programs
and data on it. Can anyone help me out here? I’m not very computer literate but could it be that comodo changes registry settings or something to prevent the browser from getting on board. Maybe I ‘Denied’ when I should have allowed? I have made firefox a ‘trusted app.’ but that didn’t help. Don’t know for sure that it is Comodo but it has happened before and when I uninstalled Comodo that time I got my connection back. this time that didn’t work. Secutrity is one thing, but one would also like to get on the internet.

Hi Roady, welcome to the forums.

I’m sorry you’re having trouble. I’ve no idea why you should be having this sort of problem… especially after CFP was uninstalled.

Anyway, I think you should go to Comodo Support, register on their system & raise a ticket on this issue.


What version of CPF do you have?

You mentioned Kaspersky; do you have (or have you had) Avast! on this machine?

Do you have Arovax Shield, or SpywareTerminator running?


Hi, the version of Comodo is It could be something else entirely, could even be a virus for all I know.
I did set up the computers side by side and copied all the connection properties from the computer which gets online to the other which doesn’t. But there are a whole mess of things in there which I was playing with while trying to connect to a small network so that is likely where the problem lies. I wanted to use the same NICs for both networks and just switch the cords to change between the internet and the network between the two computers. That didn’t work so I put in a couple of old network cards and discovered that it was the cord - has to be a crossover cord for a simple network with no hub between two computers. But I’m veering off topic here…

Then it occurred to me to try connecting with the newly installed network card. Nope, not in the other computer (although the lites come on back there and it says it is connected and sending packets, but it doesn’t receive more than about 3) , but it works fine in this computer, this message is being sent thru the new card connection. That pretty much narrows it down to software. That computer is running Win 2000 pro for what it’s worth.

The programs you mentioned (Avast, SpywareTerminator, and Arovax Shield) have never been installed but Kaspersky is still on there. Thanks for your time, I will figure it out or upgrade, no big deal.

Connection properties can be easily messed up, that’s for sure… ;D

You might also try this:

Turn off Kaspersky. Uninstall Comodo. Run a registry cleaner (Like RegSeeker) to clean up orphaned/broken entries, etc. Clean up traces of Comodo/CPF that may be left. Be sure that you create a backup copy of the registry items before deleting them.


Turn off kaspersky again. Reinstall Comodo on Automatic (not Manual or Advanced). Run the Application Wizard (Security/Tasks/Scan for Known Applications). Follow the prompts. Reboot.

Now try again, see if you get the same error about appguard.dll.

Hope that helps,