Appcrash immediately after new installation

For whatever it’s worth, this just happened…

Downloaded (today, 13 Feb 2009, from the Comodo web site) the latest/greatest version System Cleaner and installed it normally immediately after download. Installation went okay, but when I clicked on the last button to finish the installation and launch the program for the very first time, I got the following error:

Problem Event Name: APPCRASH
Application Name: CSC.exe
Application Version: 1.1.63928.28
Application Timestamp: 49918eba
Fault Module Name: imagehlp.dll
Fault Module Version: 6.0.6001.18000
Fault Module Timestamp: 4791a709
Exception Code: c0000005
Exception Offset: 00004cbc
OS Version: 6.0.6001.
Locale ID: 1033
Additional Information 1: 0f12
Additional Information 2: 816b4f10fbe8ee20a0052d1f7b1822a3
Additional Information 3: 7478
Additional Information 4: cf09a27b11bcc591eeeb20df3b4a3859

It’s a brand spanking new Dell notebook running Windows Vista SP1 with all the latest/greatest OS updates from Microsoft; and every last Dell utility updated as well. No anti-virus or other anti-exploit software of any kind is installed yet.

Once I cleared the above error, and tried launching System Cleaner from its desktop icon, it launched just fine. It was only when the installer tried to launch it for the very first time upon completion of installation did the error occur.

I remember Norton Anti-Virus used to have this problem. I learned, eventually, to never ever allow the installer to launch it for the very first time, and to just uncheck the “Launch…” checkbox before finishing the installation, then launching for the very first time manually. Once I did that, all was fine.

I don’t know if System Cleaner is going to become one that has to be handled that way as well (hope it won’t be), but even if it is it’s no big deal. It’s obviously (or at least presumably) a weirdety of the installer or something.

Just wanted whomever should know about this to, in fact, know.