App sgnd with expird cert always Unrcgnzd even if manual added to TFL [M594]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Always.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a. Tried to run a digital signed executable when required certificate is not within its validity period. (The app in question can be downloaded from here)
    b. BB automatically blocks the operation and sets the executable as Unrecognized.
    c. Manually changed exe flag from Unrecognized to Trusted (Advanced Settings->Security Settings->File Rating->Unrecognized Files->menu option: Move to->Trusted Files.
  • If not obvious, what U expected to happen: The program should be Trusted from this moment but each new attempt to start - resets its flag to Untrasted again.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS 6.2.285401.2860

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: All, HIPS=Safe, BBlocker=Blocked, Firewall=Custom Ruleset, AV=cloud is off
  • Have U made any other changes to the default config? (egs here.): No
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7, SP1, 64bit, UAC=on, admin, VM used
  • Other security/s’box software a) currently installed b) installed since OS: a= None b= None
    [/ol]

[attachment deleted by admin]

Do you mean that even if you manually add this to the trusted files list it will continue to be flagged as Unrecognized? Sorry, I’m just trying to make sure I entirely understand this issue.

Thanks.

Yes.

Please attach the diagnostics report and the KillSwitch process list to your first post.

Also, please check and see if you see the same behavior if the cloud is enabled.

Thanks.

Done

Yes, the problem exists too when the cloud is enabled.

Thank you.

Can you also attach the file you are using for testing to your first post. That would be very helpful.

Here is: https://hotfile.com/dl/236786233/3f150b4/BackupperFullFree.zip.html

The size of the file is 52 MB, so I put it on an external server.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have informed me that apparently this is intended behavior. It is a side-effect of using Blocked. Using any other BB level should not cause this problem.

@bazolo, please create a wish for Blocked to not cause this sort of an issue. I’ll also add that enhancement request to the tracker.

Thanks.

I would be grateful if we could find out if this still happens in 7.0 4132 PR.

@Chiron. Should this maybe be added to verified wishes? Just a thought, as it is quite important.

Good idea. I have now moved this to the Verified Wish section.

Thanks.

Should be fixed with CIS 10.0.0.5144. Please check and if you disagree say so here or PM a bug board moderator. Thanks