App rule stops functioning after reboot (v3.0.21.329 x64)

I have an application with specific IP allow and deny. It works perfectly for a day or so, then after reboot it has problems.

The application name has ~ in the name where it did not before. Attempting to reimport config or make NEW rules, still gives me the pop up box asking again. I’ve tried everything I can think of. On occassion, after hitting apply 3 or 4 times it will accept the rule for another day or so, then repeat the problem.

I have completely, reinstalled the application with the same error.l
I have tried to create a new rule from scratch and modified ones that Comodo creates and it does not work.

I use an imaging backup program and when I restore the system, everything works fine again for a few days, then reboots seem to cause the issue with Comodo.

Very frustrating, as this is the ONLY app I want specific IP rules for, most others presets or universal allow or deny work. Overall have been pleased with Comodo and want to keep recommending it.


You may backup your CFP settings and try new version.

Installed new, and still having same issue … occasionally rebooting helps, otherwise custom rule doesn’t work.


Can you please mention what app you are talking about, is it latest version available from that app’s developer and if so where it can be downloaded.

What are your system? xp or vista?
Please include detailed step by step description to trigger issue.

The applications I’ve notices are Skype, Newsleecher, I still notice that Comodo alert window has the ~ in the path, Wasn’t this an earlier bug ?

As to how it happens, as I said, When it occurs which seems random, rebooting sometimes seems to fix it, I’ve tried opening the rule and hitting apply again and that also sometimes clears the issue. Often, nothing will correct it.

When I restore my system (True Image), everything will work again, then 1 or 2 reboots later, the problem reappears as described.