aplication signature change popup is missing (or I am missing something)

I have to ask, whether CFP does recognize application change. I was playing with different miranda versions and once I got rule in comodo, it was OK to change the executable from 0.7.8 to 0.7.10 and CFP didn’t ask anything.
first I thought thats because I don’t use d+. So i turned it on, currently I am on safe mode, but still no warning that application signature has changed (as version 2.4 did).

I need this confirmed by others, whether cfp checks signatures and warns user, or not. And if yes, then I’ll investigating wha’t wrong.

THX in advance.

PS: fireall is set to dafe mode and alerts do medium. But the descriptions for higher levels don’t promise wanted functionality.

Evening foxx,

CFP Defense will know if you are updating or not…
since you’ll be modifying registries and other files…

but CFP Firewall Will Not unless another “child” application is connecting to the internet to update it, it’s still the same .exe name so Firewall will not alert you… so what ever you had it set on for that application it should stay the same

did this answer your question


well, partially:
this is what I did:
ran miranda 0.7.8, created rules.
exited miranda.
switched binaries to 0.7.10
run it and woila, comodo shows NOTHING.
old kerio personal did throw a popup that application has changed. comodo does NOT.
settings which I use are described in my previous post.


I understand your issue…

If comodo did not alert you it already learn’d or has alerted you before…
If you had Defense Disabled at the time of the “replacement”
Then it probably will not alert you once you have enabled it after the replacement.

If you can,
Please check The following

Open CFP > Firewall > Advance >Custom Policy > See if Miranda is listed

Defense> Advance > Custom Policy >See if Miranda is listed

Is it listed?


yep, miranda is in both lists.
and def+ was not switched off when I changed the binaries. CFP had all the time those settings I mentioned.

One thing that pisses me off, that enabling and disabling defense+ hang my computer. After reboot it is enabled/disabled as desired, but I would like to restart a bit later and definitely hard restart… (luckily the power button works so I don’t have to unplug from electricity and pull out battery :slight_smile: )

EDIT: I have disabled logging for both firewall and d+, because it causes hangs on czech windows. this bug is reported at least for last five builds and still is not repaired (last version that worked was 3.0.15… das ist schrecklich)

EDIT2: corrected second sentece, “def+ was not switched off”