Anyone noticed that CIS sometimes fails to start in Windows 7

After a bit of time on one of my computers cis fails to load and goes to diagnostic mode to see whats up, finds nothing, and then you can manually start it? is it just me, or is this something others have noticed? on 64 bit sp1 Ultimate

Do you have other security programs installed? If so which one(s) run in the background alongside CIS?

As always make sure there are no leftovers of security programs you had installed in the past. A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase .

I will look into this, thanks for the quick reply, i will report back on my findings.




Well well, here windows 7 x64 starts but with a significant increase in boot time, with another AV i have a boot time from 28 seconds and with CIS it went to 47 seconds ,the most part it hangs on the Welcome screen :-\ (boot time measured by Glary Utilities)

I have similar issues, but I can’t reproduce it.
I’m using Windows 7 SP1 x64, CIS 6.3.301250.2972 (I’ve noticed the problems with all versions of CIS 6) and my only other security software is EMET. I switched from EMET 3.5 to EMET 4.1 last week.

I’ve configured EMET to protect all executables in C:\Program Files and C:\Program Files (x86). I disabled all mitigations for CIS processes, but this seems to have no influence.
Block all unknown requests if GUI is not running is disabled in the CIS options.

  • It takes a considerable amount of time until my desktop is ready and I can start working. (May be normal)
  • Sometimes CIS GUI doesn’t load at startup as described in the opening post.
  • Sometimes I get alerts for applications at system startup, however they are listed in the Trusted Files section in CIS.
  • Very rarely I have a permanent high CPU load, which is caused by svchost.exe. I have to reboot to resolve this.

I know, that the last point is connected to CIS, since this got way better, since I switched my configuration from “Paranoid Mode” to “Clean PC Mode” to reduce my HIPS policy set to a minimum. “svchost.exe” had (and still has) assigned the “Windows System Application” policy.
There are no entries in the CIS logs, which would help me to recognize what is blocked at startup. Probably logging isn’t available at this early stage.

Are you willing to uninstall EMET for a week or so? Just to see if there is an influence of it.

The only other security program i have is Webcam anti hijack, But having said that, all my drives are encrypted with Truecrypt 7.1a, now i would not have thought that that would have an impact on the gui starting, so in my mind i have ruled this out, i will stop webcam anti hijack, and disconnect my webcam and see if this resolves the issue.

Thanks to all.


I’ll uninstall EMET temporarily and do some more reboots as usual. But since this happens only rarely on my system, it’s hard to tell, what’s the cause. I can tell you, that I had definitely no such problems with CIS 5.10 and it seemed to work fine, when I switched to CIS 6 (I skipped the initial release and switched when the version with the “advanced” summary screen and the many small usage improvements was published, can’t tell you the exact version number)

Ok, that’s a fast result.
Uninstalled EMET, rebooted, so that all remaining parts should be gone. Worked some time, rebooted again and as before - no CIS GUI was loaded, Comodo told me, that I should run the diagnostics wizard - as we already know, it finds no problem. Started the GUI manually.

After that I reinstalled EMET, since the problem also occurs without EMET.

We can now exclude EMET. Are you running D+ in Safe Mode or Paranoid Mode (assuming you’re using Proactive Security configuration)?

Please make sure there are no left overs of previously installed security programs by running clean up tools. You can find a list of such tools linked here: ESET Knowledgebase .

The reason for asking to see if this may be a bug. What other security programs do you have installed that run in the background?

I’m using “Clean PC Mode”, the alerts in question come from files in the “Trusted Files List”, I tried to create allow rules to circumvent the problem, but with no effort. Since it happens only sometimes, I guess it has something to do with the startup order. As I already wrote, the “Block unknown requests if the GUI is not running option” is disabled.
I have no clue, why the GUI fails to start completely in some cases and I’m asked to run the diagnostics utility instead.

As I already wrote, I’m using CIS 6 and EMET 4.1 only. Windows Defender from Windows 7 is disabled. When I switched to CIS 6 I did a clean install after uninstalling CIS 5.10; the same is true for the switch from EMET 3.5 to EMET 4.1. There is and was no other security software installed.
I think it’s pointless to file a bug report for this non reproducible phenomenon which happens only rarely.

This happens for me as well, although rarely.
I have Win7 x64 Ultimate, avast2014.9.0.2011, and Comodo 5.12 with Proactive and FW+hips both on Safe.
I think It happens a little more frequent when right after a cold boot I quickly switch user (I made the start so that it boots in one of the 2 user I have, without asking which one, with Run>control userpasswords2).
But it doesn’t run the diagnostic tool itself, which by the way doesn’t find any problem. I only see that the icon in tray is a big “!”.

Assuming it is Comodo Internet Security Helper Service crashing I suggest to change its recovery settings to always restart the service.