Any way to change the half moon icon? [Solved]

Help. For some reason, the “half moon icon” that is the combo BACK button and history button is driving me nuts…I simply cannot get used to mousing up there for the back button and it isn’t there!

Is there any way I can change that icon to be a “back arrow?”
see pic
Mod edit: Added solved to the topic title, Captainsticks.

[attachment deleted by admin]

Hi movrshakr,
Are you using the default theme?
What version of CID are you using?

Thanks.

Yes, “out of the box”
47.0.0.2

So, the question still stands…
is there any way I can change the “half moon” icon to a back-arrow icon?

Hi movrshakr,
Sorry for the delay in replying.
I cannot work out what is causing this.
I would try installing the portable version, which is independent from the installed version.
If the issue is not present with the portable version, I would try a clean reinstall of the installed version.
Back up important browser data and bookmarks etc.

Kind regards.

Ooooo…does that mean that the icon as I am seeing it is abnormal?
Where is that icon stored? Could I just get the right one and replace it?

I really hate to do a reinstall because I do MUCH customization, primarily due to eyesight issues. It would be painful and time consuming to go through all that again.

Hi movrshakr,
The GUI doesn’t look normal to me for version 47 and definitely not the icon.
What is the icon that looks like purple lips next to where the arrow should be?

You could try resetting the GUI to defaults.
Right click a blank portion of the tab-bar and select customise.
Then select restore defaults at the bottom of the page.

Sorry I am not sure where the icon is stored.

Kind regards.

1st icon - Lightshot (screen capture…nice one)
2nd icon - the half moon I want to be a back arrow
3rd icon - the right arrow, forward a page.

What I need to preserve for restoration is
extensions and settings within extensions
options settings
direct changes to about:config
(don’t remember what I have done there; not much, but yes one or two)
bookmarks < this is easy
userchrome.css < this is easy

I looked at Mozback; it does not “see” you.

Could you please post a pic of what those icons are supposed to look like?

I can’t replicate the issue even with lightshot installed. (Screenshot)

Could you right click the lightshot icon, select customise and temporarily move it to the other side of the address bar.

Also starting CID in safe mode would help eliminate any conflicting add-ons.
To start the browser in safe mode, hold the shift key while launching CID.

Edit: Another Mod (wasgij6) has kindly suggested maybe an issue with hardware acceleration.
Hardware acceleration can be disabled under the general tab of the advanced options.
about:preferences#advanced

[attachment deleted by admin]

pic 1 is with Lightshot moved - no change
pic 2 is safe mode - back arrow there

hdw accel off did not change it

I will disable extensions 1 at a time to see f that reveals anything.
(I hate that process!)

[attachment deleted by admin]

I found it-- pic 3
An option in Classic Theme Restorer for “Small buttons on nav bar” causes that icon to switch to that half moon. So it isn’t CID at all.

Too bad; that option gives more room on the bar and the icons don’t really get too small. It actually just seems to reduce the spacing between them so you have more room.

AH ha. But if I also turn on “Movable back/fwd butons,” the arrow version is there even with 'small" turned on. pic 4

SOLVED.

[attachment deleted by admin]

Hi movrshakr,
That is good to hear that you found the cause and a solution. :-TU

Thanks for letting us know.