Any way for Enter on search to not open in a new window?

Is there a way to change ‘mechanization’ so that when we type something in the search field on the newtab page, that does the same thing as clicking the magnifying glass ‘go’ button (instead, it opens the search in a whole new window)?

Fingers are already on the keyboard for the typing, so its easier to just hit enter.

see pic

[attachment deleted by admin]

Hi movrshakr,
This is sometimes controlled by your default search engine.
Check for search engine settings of your currently set default search engine, or try a different search engine.
about:preferences#search

Thanks.

Where are these settings?
I use duckduckgo and don’t really want to change.
Also, same search in Firefox, and there enter does not open new window.

Hi movrshakr,

Kind regards.

Edit: I have tried replicating your issue using duckduckgo, but failing to do so.
Sorry I am not sure what is happening.

Ooooo…bad for me if you aren’t seeing it. I did find a settings area for duckduckgo but nothing there looks anything at all like it would affect this.

I would assume this would be something either the page code or the browser internals controls.

Oh, this is bigger than I first thought. I have the Icedragon settings set to open new Windows in tabs instead, and in this case , it isn’t.

Try IceDragon in safe mode, this may eliminate any conflicting add-ons.

To get into IceDragons safe mode, hold the shift key while launching the browser.

Does the same thing in safe mode…enter launches a new window.

pic shows ‘open in tab’ is set

[attachment deleted by admin]

I found it. My bad.
I have autohotkey script code that sends Shift-enter when the main enter key is pressed in order for enter to work on Facebook just like it does everywhere else in the world–and give a newline–whenever Facebook is open
.
I recently modified that to a form that will work when using any of my browsers. but doing that meant I had to change it to work
‘when browser open’
not just
‘when browser open and Facebook is the tab’
.
So, a shift-enter was being sent, and apparently that is what causes it to open in a new window. The num pad enter key works normally.

Hi movrshakr,
It is good to hear that you found the cause and thank you for letting us know. :-TU

Kind regards.