Any trusted file bigger than 40MB has installer privileges [M1545]

A. THE BUG/ISSUE (Varies from issue to issue)

Can you reproduce the problem & if so how reliably?:
Yes, every time.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:

  1. Install and execute (after rebooting) any program bigger than 40 MB and signed by a trusted vendor.
    E.g. Skype v. 7.7.0.103, Opera v. 29, Dropbox v. 3.6.9

  2. Execute by this program any unrecognized file

  3. Make sure that the unrecognized program is running without restrictions

One or two sentences explaining what actually happened:
Any trusted file bigger than 40 MB has installer privileges

One or two sentences explaining what you expected to happen:
A program should not be treated as installer, when it is not an installer, regardless of its size.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
NA

Any software except CIS/OS involved? If so - name, & exact version:
NA

Any other information, eg your guess at the cause, how you tried to fix it etc:
I have suggested an option to disable automatic detection of installers for selective file groups.

B. YOUR SETUP
Exact CIS version & configuration:
CIS 8.2.0.4674
Configuration: Proactive Security

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

Antivirus:
Stateful
“Do not show antivirus alerts”: disabled

HIPS:
Safe Mode
“Create rules for safe applications”: disabled

Auto-Sandbox: Enabled, default rule set
Firewall: Safe Mode

Have you made any other changes to the default config? (egs here.):
No changes

Have you updated (without uninstall) from CIS 5 or CIS6?:
No

Have you imported a config from a previous version of CIS:
No

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win7x64SP1 (VMware), Admin, UAC is enabled

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

[attachment deleted by admin]

Hi,
Thanks for you tell us the issue ,We have reproduced the issue ,our devs are checking…

Regards

Even tho comodo has already confirmed this issue im still going to log it in the tracker.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Thanks again

Fixed in the leaked CIS 9.0.0.4725 beta. Many thanks to developers!
The sign of installer is size >200 MB in that version.

In that case, I will move this one to “Resolved” section.
Thank you.