Antivirus scan hangs on a random file

The bug/issue

  1. What you did: Just pressed “do it now” button. Pressed pause/resume a couple of times during scan.
  2. What actually happened or you actually saw: virus scan window appeared, scan worked couple of hours than I noticed that number of scanned files and current file name do not change. This bug happened many times, each time file differs, sometimes scanning stops on something evidiently harmles, for example xml file. cmdagent.exe consumes constant percentage of CPU (one time it was 25%, other time - 38%)
  3. What you expected to happen or see: scan finished.
  4. How you tried to fix it & what happened: tried to stop scan with the “stop” buton (nothing chandes), tried to close scanning window (same effect), tried to kill cmdagent.exe (can’t), tried to exit comodo and restart again (cmdagent remains running).
  5. Details (exact version) of any software involved with download link:
  6. Any other information you think may help us:

Files appended

  1. Screenshots illustrating the bug:
  2. Screenshots of related event logs or the active processes list:
  3. A CIS config report or file: configuration file in attachment.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: CIS 5.0.163652.1142
  2. Whether you imported a configuration, if so from what version: updated from 4.x, this was buggy, so I’ve uninstalled comodo and reinstalled it from the scratch.
  3. Defense+ and Sandbox OR Firewall security level: Defense+ in safe mide, firewall in safe mode, sandbox enabled, antivirus - stateful.
  4. OS version, service pack, no of bits, UAC setting, & account type: Windws 7 HP, x64, UAC on.
  5. Other security and utility software running: no other security software, installed daemon tools pro, so SPTD is present.
  6. Virtual machine used (Please do NOT use Virtual box): vmware player installed but no virtual machine running.

[attachment deleted by admin]

Many thanks for making a report in the standard format. To enable devs to determine the cuase of your hang, please append a hang dump file as described here.

Best wishes

Mouse

I am running Windows XP SP-3 on a Dell Pentium 2.00 GHz and 1.00 Gig of RAM.

I have the exact same problem on the exact same CIS version, EXCEPT that my scan started as the result of a scheduled Weekly Scan that is performed every Saturday night.

I got up this morning, more than 8 hours after the scan started (usually only takes 3-4 hours), and found that the scan is still running and it appears to be stuck on the C:\AOL Instant Messenger\AIM.exe. >:(

My system was automatically updated last week and this is the first scan that has run with the new version – very new with the new look and all.

The “Stop Scan” button does nothing, and the program does not appear in the Applications section of the Windows Task Manager. The process does not appear in the Windows Task Manager under Processes either, as far as I can tell. So I can’t shut it down that way.

This is so reminiscent of the problem that occurred last year when my CIS was automatically updated and I and a lot of other users was eventually instructed to uninstall the old version through a lengthy process, then download and reinstall the same version.

It fixed the process but it took many hours, and the download is a major pain since I am on dial-up.

It goes without saying that this is a major pain. Since I can’t stop the process, I’m going to have to do a forced shutdown on my system and restart. And I’m going to shut down my scheduler until this is resolved. >:(

But more to the point, since Major Upgrades don’t appear to be safe for everyone through the automatic update process, why are they continuing to be allowed? ???

I bet if you turn Cloud Scanning off for Manual or Scheduled Scans you won’t get a hang.

https://forums.comodo.com/antivirus-help-cis/comodo-av-takes-9-hours-to-scan-t36832.0.html;msg444397#msg444397

Thanks.

But that’s no go for me. I don’t have Cloud Scanning turned on for either Manual or Scheduled.

:slight_smile:

OK, worth a try ;D

This is funny, but I can’t create dump. First, when I tried to create dump of cmdagent using windows task manager, I’ve got “permission denied” error. Then I’ve switched off D+ and tried again, I’ve got “writing process to file” message which stays forever. Moreover, all my system hanged after this attempt: I could move mouse, even some windows work for some time, but I couldn’t start any new program and running programs have stopped responding after some time. Looks like dump file creation routine stopped some system essential service, such as paging or something.
I’ve rebootted PC and started again. Today I’ve got scan hang again, switched of D+ and tried to create dump with same result.
Than I’ve pressed reset again, tried to create dump of some other process (opera browser) and this was succesful. Than I’ve started virus scan, and tried to create dump before it hangs. Same result - all system hanged.
Looks like CIS has something like “self-protection”, which prevent dump file creation.
Maybe this problem somehow connected with my paging file organisation: I have 3 harddrives and pagefile distributed among them.

Sorry just noticed a bug in the process for Win7/Vista. You’ll need to all taskmgr.exe interprocess access to CIS in the same way as process explorer. I’ve updated the guidance on the original link I posted.

Did this, but still dump creation lasts forever. Scheduled harddrive check, maybe something with file systems.
The good thing is that now I can kill hanged cmdagent.exe :).

Maybe try process explorer? (Just follow the guidance for XP instead in my note). You are changing the protection settings on the CIS group, by adding an allow entry. Easy to get this wrong!

Any luck Chocky?

Dump of CIS 5 versus process explorer works here, so maybe scan is inhibiting?

There is also the handle watching method described here.

You might also try:

  1. Excluding *.mzz files from scanning under Antivirus ~ Scanner Settings ~ Exclusions ~ Add ~ Browse. Please say if this works.
  2. Monitoring your internet connection while scanning maybe using Routerstats (Just Google it), to see if the hang coincides with internet access failure.

OH or easier than 2):

  1. disabling Cloud-based scanning in AV ~ Scanner settings ~ manual scanning & automatic scanning

This will tell us if it’s a Cloud issue.

Best wishes

Mouse

Mouse, I suggested that to him on the 3rd as his problem sounded a lot like mine. He replied he didn’t have Cloud Scanning on.

Mark

Sorry missed that!

I’me very sorry but without some means of dentifying the file, the developer will not be able to address this issue. I realise this is not your fault, but for the moment I am forwarding this as an incomplete report.

If you do manage to get a dump file, please ask any mod to move this to verified.

Best wishes

Mouse