Antivirus not allowing program to run

Hello. I re-installed Comodo today after seeing it recently got updated. This time around I installed the AntiVirus as well to try and have everything in one place.

But of course, I hit a snag. I tried running TuneUp Utilities and it won’t load up I get an error message:

“The application failed to initialize properly (0xc0000022). Click OK to terminate the application.”

The antivirus thought a file in the TuneUp folder in Program Files was a virus or something.
So I restored it from quarantine thinking it would fix the problem. Nope. Still get the error message.

I assumed it could be Defense+ causing issues.
I disable defense+, issue persists.
I disable firewall and defense+, issue persists.
I enable firewall and defense+, since Antivirus MUST be it.
I disable Antivirus, problem solved. Application opens and defense asks it’s usual “Want to allow this?” stuff.

I have the .exe both on my desktop and in the program folder added to the exceptions in antivirus settings. And anywhere else i could find to add a trusted application or w/e; I did it.

So am I missing something simple or is this more involved and I should uninstall and reinstall it with just the firewall and go back to using AVG?

Try deleting all D+ rules regarding Tune Up Utilities and start Tune Up Utilities again. Does the same thing happen? When the AV pop ups for one of the Tune Up files put it to the AV exclusions.

hi ErikJH. I also have a problemm with CAV:when I try to launch TuneUp 2008(I like v.2008) my CAV tell me that it found a virus,and tell me often,for every file,updater,.dll,.exe,etc;it’s very annoying to put every file of Tuneup in Exclusion.
any suggestion?
thanks in anticipation.

You could always submit the files to Comodo to stop the false positive detections. (Assuming they are FP’s)

Comodo Malware Analysis

Other than that, have you tried just excluding the whole tune up utilities folder?