Antivirus mode changes randomly to Stateful from On Access

A. THE BUG/ISSUE (Varies from issue to issue)

  • Summary - Give a clear summary in the topic subject, NOT here.

    • Can U reproduce the problem & if so how reliably?: Yesterday I’ve seen that CIS V5 wasn’t updated from august, so I thought it was a good opportunity (since diagnostics didn’t help) to install V6. Removed CIS V5 from Revo Uninstaller with the best removal method + double checked with the (unofficial) tool to totally remove CIS twice. Plus checked for leftovers myself in the folders and registry.
      The installation went fine, but now everytime when I change the Antivirus mode to On Access (that’s how it was in V5), it changes back after unknown time or reason back to Stateful.
      Don’t know how to reproduce. However, when it happens and I flip to Advanced Mode I can see the On Access changes really fast to Stateful.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: I wrote everything ^
    b:
    c:

    • If not obvious, what U expected to happen: Obvious :slight_smile: I want it to stay as On Access…
    • If a software compatibility problem have U tried the conflict FAQ?:
    • Any software except CIS/OS involved? If so - name, & exact version:
    • Any other information, eg your guess at the cause, how U tried to fix it etc: I tried changing it back to On Access and it went back to Stateful…

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)

  • Exact CIS version & configuration: 6.3.302093.2976, database version 17384
    • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: HIPS - safe mode, Firewall - safe mode, Autosandbox - Partially Limited, Antivirus - needed On Access, currently Stateful.

    • Have U made any other changes to the default config? (egs here.): Disabled widget, enabled scanning optimizations, disabled scheduled scans, enabled HIPS on safe mode. COMODO Dragon and others aren’t installed.

    • Have U updated (without uninstall) from a CIS 5?:Made a full uninstall first to CIS 5, including removal using Revo Uninstaller and the unofficial tool to remove COMODO products.

      [li]if so, have U tried a a clean reinstall - if not please do?:
      [/li]

    • Have U imported a config from a previous version of CIS: Nope. I made some reseach before installing the new version.

      [li]if so, have U tried a standard config - if not please do:
      [/li]

    • OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7 SP1 x86 Hebrew, UAC disabled, account admin, V.Machine? You mean like VirtualBox? installed but irrelevant since CIS 6 is installed in the main PC.

    • Other security/s’box software a) currently installed b) installed since OS: a= b=

    • Wow… can’t remember. But I do have MBAM, HJT, SuperAntiSpyware, Panda USB Vaccine.

Thanks.

[attachment deleted by admin]

Thank you for reporting this. I have changed my settings to on-access and will see if it occurs on my end as well. By the way, how long does it usually take to change (just a rough estimate)?

Also, can you confirm one thing? I just want to make sure. Did you import any configuration into CIS, or did you create any changes from scratch?

Also, can you please attach your current configuration file and a list of the processes currently running on your computer to your first post?

Let me know if you have any questions.

Thanks.

I installed CIS V6 yesterday and it changed about 5 hours or so. When I doubled checked the settings (then I didn’t know the issue existed) I saw it was back on Stateful and it made me mad LOL. I thought I was the crazy one :slight_smile:
And it happened today as well…
By the way, I know see the Enable scanning optimizations option unticked itself too… same issue as On Access thing.

Hold on… while writing this post I read this post-
https://forums.comodo.com/antivirus-help-cis/on-accessstateful-t37703.0.html;msg269343#msg269343
It made me wonder… are the Enable scanning optimizations and On Access somehow related? If so, it isn’t a bug but a misunderstanding :slight_smile:
I jst made some test and when I check the Enable scanning optimizations, Stateful appears. When I uncheck it, On Access returns.

If it isn’t normal, so no, I didn’t import any configs, and created all the changes from scrach.

How can I attach my config file and the other thing? Print screen?

Thanks.

You are correct. Part of scanning optimizations, in fact the necessary part, is Stateful scanning. Thus, switching scanning optimizations on will turn on Stateful Scanning. Were you experiencing any other issues, or does it now seem to you that this is not a bug, but just that the two settings are linked?

Thanks.

Guess not.
I’ll check it out and post here if there will be any changes on the subject.

Thanks for clearing that out :slight_smile:

Thanks. In that case I’ll move this to Resolved. Let me know if it turns out this is in fact a bug.

Thank you.