Antivirus engine will not initialized!

Comodo Anti virus engine will not initialize… Tried to update AV and receive an error. I shutdown CIS and restarted and get same results. Re-booted and same thing… I have not performed any updates. running 1236. What happened???

What happens when you run the diagnostics?

Did you run the diagnostics?

Please make sure that the Comodo Internet Security Helper Service is started (Start → Run → services.msc)

Didn’t think of running it… I uninstalled and installed most recent release although I know there is no big change in 1237. Virus Sig’s updated successfully and running a scan now…

hi every body
i have the same problem engine will not initialize when the system goes on standby.
OS : xp sp 3
cpu : pentium 4

Does running Diagnostics help?

When it doesn’t help then there could be another security program interfering. Do you have another security program alongside CIS? Which one(s)?

Or may be there are left overs of a previously uninstalled security program. What program did you use before CIS? Try running the removal tool for that program. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

i ran Diagnostics and i uninstalled security program with Revo Uninstaller and registry search for leftovers .

I don’t understand why programs that are designed to uninstall a program leave files behind. Why are they only doing part of their job?
Whatever files are put on the computer when the program was installed should be removed when you choose to uninstall the program.
I am not able to update the CIS program due to a message I get when I try to update it saying the file is missing. I have uninstalled the program and reinstalled it but that doesn’t help.

What scanners other than Comodo’s do you have running in the background? What happens when you try to disable them?

What security program did you use before that are uninstalled? Try running the removal tool for it just in case Revo missed something.

Hi!

I have the same problem with CIS x64 5.3.181415.1237

The Windows.7 Security Center gave me a warning, that Comodo AntiVirus is yet not started and asks if I wanted to start it. If I tell him to do so, I am asked if I really trust this program and should be careful (what I find quite weired, but whatever…). So I click “Yes, start it”, then nothing at all happens and the error in the Security Center stays.

So I check CIS and run Diagnostics; without any errors - everything is all fine. All systems are started, AV-Engine officially is “stateful”, there are no updates whatsoever, all the happy people here…

Only when I try to run a system scan it will give me this nice msg-box:

Update failed. Antivirus engine is not initialized.
When I check in to "About" I find this:
Virus Signature Database Version: [b]0[/b]

Fine.
Now I reinstalled CIS x64 just four weeks ago, due to this particular error - only that back then I haven’t got so deep into it and just thought it might have been an error in the installation or by going through a update. Now this seems to happen frequently… Is CIS really ready for x64? In my process list “cmdagent.exe” is the biggest consumer of CPU - now this … hmmm. :-\

And yes, I have checked the services, the startup routines and everything else I found related to this error. I cannot restart the service (what I again find weired), but officially it is active.
So, right now I am reinstalling again and think about other options when this happens again in four weeks…

Don’t get me wrong: I don’t intend to bitch around on things I got for free and I do of course have a lower expectation on thing I haven’t paid for. However, my personal opinion is, that when I give out whatever to the world, for how much or less whatsoever - it should be working okay. On days like these I feel like a ■■■■ Beta-Tester that wasn’t asked if he wanted to participate in a field test… :frowning:

My suggestion: Get deeper into your diagnostics software. If that thing can dig out issues and track down where they came from, you guys probably can boost ahead with great software in the next generation.
Another suggestion: Make it (generally) possible to check the installation and reinstall corrupted modules. If I had an i.e. a infection on my system I’d maybe like to have hashes of my protection-software double-checked online and reinstalled if they maybe got corrupted, and so on.

After this experience with the diagnostics app I must say, that I couldn’t trust the AV anymore after a virus would have been detected. It just seems to check if the CIS container is running, not if it impacts in case of danger…

Now again I have to reinstall the whole suite; all my settings are gone again, I have to re-setup my network and so on … that’ll cost me the next (at least) two hours. Shit.

Best thing to do to make sure that there are no left overs of previously uninstalled security programs around. Not all uninstallers do a proper job. And left over applications, drivers or services can cause all sort of “interesting effects”.

Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Hi,

I can confirm the issue posted by simon.saint. I have Win 7 x64 as well and I never have another AV software installed but CIS. ???

Please make sure Windows Defender is not running. When it is disabled does the problem persist?

hi, i have a problem with AV, when i actuallized IE in my Windows 7 to top version my AV don’t get a database update, i have a error comunicat with “Comodo Anti virus engine will not initialize” reboot system don’t help, diagnostic tool tells me that everything is ok, but AV don’t update, pleas help. my OS is: Windows 7 Home Prmium

Edit: ok, my CIS is now working good, i instaled CIS again and that was inaf to runing AV, i think that was problem with my new mous

Windows Defender had been disabled. It was the first thing to do after Win7 installed.
I run the Comodo diagnostics tool, but it says no problem with the installation. :o

At all people who reported. When you excluded other security programs and possible left overs from being the cause please consider filing a bug report; that would greatly help Comodo.

You can file the bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

I filed a new bug here: https://forums.comodo.com/bug-reports-cis/antivirus-engine-is-not-initialized-t71458.0.html;new#new

Right now I don’t have the time to file a bug report - sorry.

But like I thought and said before, reinstalling solved the issue … probably again for the next few weeks.
And No: I haven’t had any other AV installed on this system. Upgraded from WinXP 32 to Win7 x64 with a clean install and heard about the x64 CIS before that, so this was quite the first thing I downloaded and installed.

Again; if you see any chance to upgrade the diagnostics tool, this might be a nice thing. Maybe benchmark it, by releasing a “Comodo Virus”, so either one that doesn’t actually do damage, or even just a empty file of no use at all, what’s just in the AV Database for diagnostic matters. When diagnostics then run, the virus is being released but not picked up by AV, you know something is wrong.
Then take a mem dump, Defender Status, etc. from there off or what-ever else you programmer guys have in mind to figure the issue/bug… (just talking smart, while I don’t know nothing about such stuff) ;D

I’d also like to say I have the same issue. I am on Win7 x64. Just by now I see that AV didnt worked since may 2012!
I didnt get any warrning about AV not working - it simply and quietly dint worked. Few days ago by acciddent Ive tried to scan drive and bump: AV engine not initialized!

Just a moment ago Ive tried to uninstall C-ICS using the special tool available on Your forums but it got even worse - later on I couldnt reinstall Comodo - simply boot loop - installer told me that it need to restart computer to install but after restart the same message tells me to reboot over and over. To make matter even worse my internet stops working.

Ive managed to restore windows to previous restore point but now I simply wonder what to do. AV engine is not initialized. Ive tried to disable defense+ but nothing changed, Ive also tried to start AV from windows security actions control panel but also no go.

Additinally I dint install any other AV engines ever on this computer.

I love comodo and I dont mind using great free product and be a guinea pig (like few years ago when AV update delete essential windows system files rendering mashine inoperational and in need to reinstall whole windows and stuff again…) but please tell me what should I do to solve the issue.

Kind regards,

Hi nabuhonodozor,
First up sorry to hear of these problems.
In some instances of a failed uninstall/reinstall, the older original cleanup tool run in Windows safe mode comes to the rescue.
Please try this tool in Windows safe mode before re-installing.
Clean-Up Tool for Comodo Internet Security (OLD)