Antivirus engine not initiated

When i want to perform a scan CIS showing an error msg “Update failed. Antivirus engine not initiated.” I checked for updates and database is uptodate.

Attched prnt scrn of erroe msg. Please help.

[attachment deleted by admin]

Please try running the diagnostics and see if that can solve the problem.

Yes i tried diagnostics. It didn’t find any problem.

In my opinion the easiest fix is probably to uninstall it and then reinstall it. To do this please follow the advice I give in this post.

Note that if you have made a lot of rules for applications you may want to export your configuration before uninstalling. Then, after the new one is installed, you can import your old configuration. This way you won’t have to recreate any rules.

Please let me know if you have any questions.


Hey, Thanks I’ll try it.

I encountered this problem many times. A few times it was resolved by itself but usually I had just to reinstall CIS.

My experience has shown this to invariably be a horked AV defs file. The evidence for this is manifest in the 'MORE" tab and select 'about CIS". When the AV database signature is ‘0’, the defs file is horked. I’ve found that the surest sign this is an issue: previously trusted apps begin to become sandboxed. :o

This can be resolved one of several ways:

Reboot into safe mode. Using WIndows Explorer: drill into C:\Program Files\COMODO\COMODO Internet Security - or the appropriate location particular for your installation - drill into the scanners folder and delete the bases.cav file. Reboot. In a perfect world CIS will copy …/repair/bases.cav to …/scanners/bases.cav

IF the AV database signature is <> ‘0’, try to update the AV database again (if it works be happy with ‘works now’). IF the AV database signature is STILL '0’though, then the copy the AV update made is also horked, i.e., BOTH …/scanners/bases.cav AND …/repair/bases.cav are horked.

The only way out of that mess is to download a copy of the current AV database from Comodo AV database server:

IF this problem happens frequently, there’s either a bug in the program OR there’s a system memory problem. To diagnose the latter issue: download and install 7-Zip from the above URL. In ‘tools’ there’s a benchmark option. Run that and ensure that the dictionary size is appropriate for the amount of RAM installed. Select the largest dictionary size such that memory useage is nearly all the RAM installed.

The 2 part-test should complete w/out error. The first part simulates a compression and the second part simulates extraction. Neither part should error. IF you let it go it’ll continue re-running the 2-parts indefinately.

IF you get any kind of error in the 7-Zip benchmark there’s a memory gremlin running around your system. Resolving memory errors is beyond the scope of this response; it IS however the root of repeated CIS AV data-base update failures.

IF the 7-ZIP test garners no errors after several iterations, e.g., 15 minutes of execution, then errors plausibly can be attributed to some arcane CIS AV bug.

The least tastey solution: clean re-install.

But IF you DO have memory prollems: no guarantee that’ll work either.

One of the surest signs of memory prollems related to AV defs: downloading the AV defs manually and then you can’t extract contents 'cause the file is corrupt. Sometimes that may actually work. But invariably you’ll have more prollems.

What happen if your systrem just happen to be writing to the registry with corrupted memory contents?