Antivirus Engine Not Initialized

I’m having a peculiar issue with Comodo at the moment. I can (and have) updated fully. However, every time I try to run a scan, I get the message “Antivirus Engine Not Initialized!”

I checked the solution posted in the FAQ, but it seems it requires Comodo to update itself to fix the problem. However, as I stated, I’ve already fully updated Comodo so trying to update again will not (and has not) solved this.

Any suggestions? Or should I just do a complete reinstall of CIS?

OS: Windows 7 (64-bit)
Verison of CIS: 5.4.189822.1355
Virus Signiture Database Version: 0
Other security software: None
Date this first occured: May 8, 2011

Welcome to the forum Lunar Savage :slight_smile:

As your Virus Database is 0 update will fail as the database is corrupt, it has to be 1 or higher to succeed.

Please follow the instructions here
https://forums.comodo.com/antivirus-faq-cis/where-can-i-download-the-latest-full-av-database-t47164.0.html

Dennis

Hi Dennis,

Thanks for the advice. However, I followed the instructions exactly. It did not work. I’m still getting the same message when I try to scan. On top of that, Comodo says the product is fully up to date. At this point, I’m just considering a re-install.

-Lunar Savage

To take a different angle. May be left overs of previously installed security programs are in the way. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

Comodo is the only security program I’ve had on this system (I should know, I built it after all). However, I’ll try running those on Comodo itself and see what happens. Will report later tomorrow. Right now, need sleep.

-Lunar Savage

No, that didn’t work either. :confused:

Do you have other programs installed that interfere with networking? Or another security program? Try disabling them and see if that brings a solution or not.

Im currently having the same problem with my system Lunar. I cant figure it out and have tried doing everything I know. Like you I have updated Comodo and dont have any other antivirus programs…

Hello arwyn35. Welcome to the forums.

Could you start your own topic? That way this topic does not divert and your problem will get the full attention it deserves. When making a new topic tell us more about your system: what OS, what other security programs you have and if they run on access or only on demand?

Nope. Nothing like that.

It looks like there is something with your particular set up that we can’t get a finger behind. In that case please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

I just had this very same thing happen today. The suggestion above worked.

FWIW: after attempting to update AV I received the fail message. Retry resulted in the aforementioned condition, i.e., AV AV engine not initialized (AV def v0). ALSO at this time the safe files list became ineffectvie. THAT has been an ongoing probelm about every 3 weeks since 11 Mar 1. I noticed that the two bases.cav files had the same time/date stamps for created / moified & accessed.

In any case I downloaded the above mentioned file and installed it in safe mode. On reboot my safe files were recognized. I then manually updated AV. The AV incremenal defs downloaded and installation immediately failed. I immediately retried and CIS downloaded about 15 files of 0 KB each and then spun its gears installing and activating AV defs. Success. However, CIS didn’t recognize any of my safe / trusted files.

After rebooting again, CIS is back up to snuff and all my safe trusted files are recognized.

At this time the only thing different about CIS is that I altered the CIS Helper Service recovery to ‘restart automatically’ on first and second failures.

This is the first incident where there appears to be a link with the AV and safe files. In previous incidents where safe files went vapour I don’t recall what the status of the AV defs was.