Antivirus engine not initialized [Merged Threads] - [RESOLVED]

When I try to update or do a scan from the Antivurs tab I get the above error.
Why is it not initialized?

Evening, and welcome to the forums :smiley:

What OS And other security programs do you have installed on your machine?

Also, Maybe try to do a diagnostics? (CIS > Misc > Diagnostics)
Did it report errors?

CG

I have the same error message.
Windows Vista Business (32 bit)
Comodo Internet Security v 3.5.55810.432
No other security programs, other than Windows ones (Defender, etc)
Comodo Diagnostics reports “The diagnostics utility did not find any problems with your installation.”

Virus scanner won’t update. Says “Antivirus engine not initialized” - otherwise everything seems to be working. Windows Security Centre reports that “Comodo AntiVirus is out of date”

Any solutions???

I just recently received the same, cannot scan nor update as the AV is not initialized.
Windows Vista Ultimate x64, CIS (AV on-demand), Avast (AV on-access).
Diagnostics says there is a problem, but cannot fix it.
Diagnostics also asks, because it cannot fix this, if I wish a report generated. Answer ‘Yes’, give it a name, but cannot give it a ‘Type’ to save as, therefore no file is saved.
I am not interested in reinstalling at this point if there is a new update coming out soon.

Yeah… I uninstalled and re-installed and still have the same problem. During re-installation it was able to update the virus database, but when I try it manually, I get the same error as before. Automatic updates do not work again either.

Even with the current update out today, as with Avatar1, same result.
Suggestions anyone?

Hi all!
I got the same problem here. Vista SP1 with latest updates and CIS 3.5.57173.439. Any ideas and/or solutions? I hope someone can help.

Same problem. I installed today CIS 3.5.57173.439_XP_Vista_x64 and there is no Antivirus option in menu.

OS: Windows Vista Ultimate 64bit SP1

Pursuant to this thread
https://forums.comodo.com/anti_virus_help/antivirus_engine_not_initialized-t30667.0.html

I decided to post a bug report. My specs are listed below but in the above thread you will note that others have different specs and are getting same error.

Vista Business SP1 32-bit
Comodo 3.5.55810.432 (others with this problem have newer versions)
Error Message “Antivirus Engine Not Initialized” appears whenever you click the Update button on Antivirus page
Diagnostics reports that Comodo is functioning properly. Comodo service is running, appears OK. Stopping & restarting service has no effect.

My situation does not apply as in the other antivirus can’t update thread, since symptoms are different, mine is a fresh install (not an upgrade) and all my registry keys are as they should be.

Antivirus updates seem to occur on first install. If I remove Comodo completely and re-install, the antivirus updates will work the first time, but not on any subsequent tries.

For the time being I have swiched to using another company’s product, but I would like to see this get fixed. An antivirus is useless without updates!!! :frowning:

Everytime I try to update this is the message it says. Please Please Please can someone help?

Thanks

SaSuz

Same problem here. I’m using windows xp2 with CIS_Setup_3.5.57173.439_XP_Vista_x32 package.
Comodo warns that the Antivirus signature database is out of date. But when I try to update it is says “Antivirus engine not initialized”.

Diagnostics do not report any error.

Judging from the earlier posts, it seems to be a common problem. Not being able to update virus signatures is a show-stopper. Is there a fix for this yet?

I have the same problem “antivirus engine not initialized” after I updated for first time, i think is a bug in “Comodo Internet Security” ,but no updates for fixing this bug ! ??? (:AGY)

I have the exact same problem,diagnostic reports nothing.

As much as I didn’t wish to, I had to remove CIS, and do a clean install to re-initialize the AV engine.
Seems fine now.

I reinstalled > made update> restart > same problem with AV - failed

I decided this was a bug in the AV program so I made a post here

https://forums.comodo.com/anti_virus_bugs/antivirus_engine_not_initialized_with_cis_3555810432_and_newer_vista-t31824.0.html

You guys can add your comments to it.
Sadly, no one from Comodo seems to be working on this or care. :frowning:
I have switched my AV product. IF this issue gets resolved soon I might switch back.

Uninstalling and re-installing the product only allowed me to update definitions during install, but broke again immediately.

This problem just started with me also, everything was working
fine before the last update.

I cleaned all traces of comodo from my pc and reinstalled but after the first
update it quit working.

I hope this is fixed soon!! or i may have to switch back to avg.

yeah, got the same problem

I just removed and reinstalled CIS with the AV enabled the AV update went fine but when I went the run a scan I got the same message. The CIS diagnostic says there is nothing wrong with the Install.

Previously I was running Avast Home edition

Current config
XP SP3
FireFox 3.05 (primary browser)
IE 7
CIS AV & Firewall with D+
Safesurf with the toolbar disabled

I also have the same problem. Tryed to uninstall and reinstall both AV and CIS even tryed a older version but end up
with the same problem.

PC setup is:
Vista Ultimat SP1
CIS(Lates Version) with SafeSurf

CIS have run fine before so I hope this erro get fix soon.