Antivirus engine is not initialized!

The bug/issue

  1. What you did: I opened CISP, switched to the Antivirus tab and clicked on the Update Virus Database menu.
  2. What actually happened or you actually saw: I saw a popup error dialog with the following message : “Update failed. Antivirus is not initialized!”
  3. What you expected to happen or see: I expected to see the update progress dialog.
  4. How you tried to fix it & what happened: I turned off Windows Defender and it not solved the issue. I also checked that cmdAgent helper service is running. The diagnostics tool in CIS reported no problems with the installation. I reinstalled CISP and it fixed the problem, but after a week I got the above error message again.
  5. If its an application compatibility problem have you tried the application fixes here?: Not applicable.
  6. Details & exact version of any application (execpt CIS) involved with download link: Not applicable.
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Yes I can, see in section 1;
  8. Any other information (eg your guess regarding the cause, with reasons): Maybe its related with the Windows 7 Service Pack 1, because I never have this issue before.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
    http://i52.tinypic.com/2zei82b.png

  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: Attached.

  3. A CIS config report or file. Attached.

  4. Crash or freeze dump file: Not applicable.

Your set-up

  1. CIS version, AV database version & configuration used: CISP v5.3.181415.1237, Virus signature database version: 0, virus database has been updated on: 4/1/2011
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No.
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): I dont know.
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Clean PC mode, Sandbox= Enabled, Firewall = Safe Mode , AV = Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Ultimate, Service Pack 1, 64 bit, Notify me only when programs try to make changes to my computer, Administrator
  7. Other security and utility software installed: None.
  8. Virtual machine used (Please do NOT use Virtual box): Not applicable.

[attachment deleted by admin]

Please note if the virus database is 0 as you have posted it will always fail (Possible corrupt database caused this) it needs to be 1 or higher.

Virus signature database version: 0, virus database has been updated on: 4/1/2011
Please follow the instructions here [url=https://forums.comodo.com/antivirus-faq-cis/where-can-i-download-the-latest-full-av-database-t47164.0.html]Where can i download the latest full AV database?[/url].

Thank you

Dennis

Thank you for your help, it solved the problem. :slight_smile:
I just wondering what caused the corruption of the bases.cav file if it is protected. :-\

i have this issue too.

i am now trying to replace the bases.cav as recommended above, but the only version i can download is for CIS 5.3x. i have CIS 5.5x.

i hope this works.

will post updates.


UPDATE:

downloaded, extracted, renamed, replaced old file.

IT WORKS!!!

CISP will update the database file to the newest version.

:-TU :-TU :-TU :-TU :-TU