Antivirus cannot update database

Here is screenshot of the error message when I trying update database…

Here is my version CIS (5.5.195786)…

My Internet connection settings just fine, because main program updates checking goes well…

I think there is something wrong with antivirus’s update checking mechanism or with database’s servers or something else, I don’t know. Can anyone confirm this? So, here is question - when that bug will be fixed? Thanks.

I’m so sorry, but I cannot provide detailed report in appropriate terms, because it too complicated. So, there are the reason to delete this topic.

Shall I move your topic to the AV help board?

Your screenshots shows AV database 0. Try a manual download following Where can i download the latest full AV database? and see if that fixed it.

I am having the same problem. However, I can update the antivirus database using a dial up connection. But as soon as I switch back to the high-speed connction, I get the update error. What is up with that?

Can you surf the web when using the high speed connection?

Yes. Also, Comodo antivirus updates fine on my Windows 7 notebook using the high-speed connection. Is there somewhere in Comodo that you can specify what connection is being used? I know you can specify in the Avast update parameters what connection is being used.

i have the same problem too. my desktop PC (winxp) can never update the virus database. My laptop (Win7) updates no problem over the same network. Web browsing etc is all fine on the winxp machine.

just reinstalled CIS to see if it would fix it, but still having the same problem.

Comodo itself seems to update fine on the winxp, it is just the virus database i have a problem with.

Diagnostics finds no problems with my setup.

I am running 5.5.195786.1383, virus database version 1


Just installed the full AV database so my virus signature database version is now 9249. But it still wont update the database automatically.

Are you using a proxy server for your connection then you need to set Comodo to set that proxy too. That can be done under More → Preferences – > Connection

I am not using a proxy server.
Here is the sequence of events leading to the update error.

  1. Comodo antivirus automatically updating daily using Netzero dial-up connection.
  2. Connected to Internet using Charter high-speed, Comodo antivirus stop updating.
  3. Uninstalled Comodo completely. Reinstalled Comodo 5.5.195786.1383, virus signature database versiion:9429.
  4. Comodo antivirus stopped automatic updating (it doesn’t even ask) and gives “Failed to update the virus signature database” error when I try to update it manually.
  5. Disconnected Charter and connected using Netzero dial-up connection. Virus database updates normally.

I am running XP sp2 on this machine.

This looks like a networking issue to me. That’s the angle I will take on this.

Try disabling Block fragmented IP Datagrams and see if that does the trick or not.

not using a proxy either. changed the fragmented ip datagrams setting but no luck :frowning:


At SBrew. Can you surf the web normally?

At wwallgren and SBrew. Can you both check the MTU (Maximum Transmission Unit) size of your NIC? You can use the freeware system analysis program SIW for that; in SIW look under Network → Network Information.

Hi Eric
yep, i can web browse fine. the only problem is see is with updating the virus db in CIS.

SIW gives an MTU size of 1500 bytes for my LAN connection.


I am connecting to the modem through a USB port because my ethernet card isn’t working. Could that be causing the antivirus update error?

OK, got my ethernet card working and still get the “failed to update” error. The update works on my laptop using the very same network connection! What is the deal? I still have to use a dial-up connection to update CIS antivirus on my desktop computer. Absolutely ridiculous! Somehow CIS thinks I’m using a dial-up connection to the internet. Is this a registry setting?

What are your settings in the Connections tab of Internet Properties (Control Panel)? Is it set to “Never dial a connection”? If not please set it like this and try again.

Hi Eric,
Thanks for replying. “Never dial a connection” is selected under the connections tab. Another strange thing is that “Check For Updates” under the “More” tab in CIS, does recognize the high-speed connection. But the “Upate Virus Database” option does not.

I am kinda stuck at the moment. I asked the other mods to come and take a look.

There is one thing you could try. Start the command prompt and execute from there the following command: ipconfig /flushdns .

This has become an issue once again. I was updating the definitions with dial-up, but now it won’t keep the connection long enough. Why does CIS insist on a dial-up connection? Is it a registry setting? Could you please find out why CIS will not recognize the high-speed modem.

Thank you.