Anti Virus will NOT UPDATE - Again

I have just installed Comodo CIS premium and find the AV will not update - exactly the same problem as others in this forum. I CAN’T BELIEVE IT - this is the very first action required of this CIS and it does not work. Fabulous - really gives me confidence. And as for some of the solutions suggested on this forum, what on earth? Bases.CAV? Proxy this, that or the other? None of this is any use to me or any non-techie geek.

If someone can suggest a simple solution soon, I might give it a try but my first thought is to cut and run - and post on every board I can what a useless application this is. Immediate uninstall very likely. :-TD

When you install another anti virus or anti malware scanner can it update its definitions or does it fail too?

I know I’m not the OP in this thread but I just came across this same problem on a machine I installed CIS on. I removed McAfee from it before installing CIS however I did note that McAfee was not able to update itself either.

I’ve gone through the machine top to bottom and, as far as I can tell, it’s clean. (In the process of going through it one more time right now actually, nothing thus far.) The box in question is a Gateway running WinXP Media Center on an AMD Processor (Athlon X2). The Virus DB updater is the only thing that refuses to work (the actual COMODO program updater still works fine) but again, McAfee wasn’t updating either before I removed it.

Hope this helps a bit. I’ve also disabled all startup entires and unnecessary services and it still will not update.

I’ll update this post with any other info as I get it.

EDIT: I did a manual major update to the VDB and then tried to run the updater again and it still refuses to work.

EDIT2: It also might be helpful to note that I cleaned this machine about 1-2 months ago and removed a nasty fake A/V, can’t recall the name of it offhand but it made a mess. I did have McAfee updating normally after that ,but again, that was ~2 months ago.

EDIT3: I’ve been back through the machine again and still nothing as far as malware is concerned. I’ve also tried installing avast! and it wouldn’t update either so it’s obviously not just a problem with CIS. In any case it’s still a serious problem though.

EDIT4: Just installed AVG 2011 and it updates just fine. Only A/V I’ve tried so far that’s worked.

EDIT5: Last edit of the day I promise. It appears that it must be something on the machine keeping it from updating as it’s not even sending a single packet over the network when an attempt to update is made. AVG is still the only A/V that actually updated and I’ve tried Norton and Kaspersky since then (as well as CIS again).

Sorry for the double post but I managed to fix the issue and others might find this helpful at some point.

The problem was in the registry. In the following key:

HKEY_USERS.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings\

There were two entries “Proxy Enable” and “Proxy Server”. “Proxy Enable” was set to 1 (dword) and “Proxy Server” was a string value pointing to It would be interesting to note that Internet Explorer (nor any other browser or network setting on this computer) points to a proxy, just that registry key. Delete the “Proxy Server” key and set the “Proxy Enable” to 0 and reboot the machine and viola, problem solved.

If this doesn’t seem to solve the problem for you go back into the registry and see if the values for those keys changed back. They were doing that to me and I had to edit the permissions for the Internet Settings key so they’d stay the way I wanted. I DO NOT recommend doing this however, I’m still working on trying to identify exactly what keeps changing them back.

EDIT: Hitman Pro will identify this for you if you run a scan with it and will remove the registry entries. Again though, keep an eye out after restarting to see if it comes back again.

Hi Broigel. First up sorry to hear of your problems. !ot! Nothing in life is perfect in every situation, every program will have some hiccups on some systems. What works well for one may not for another, it does not make it a useless application. Everything in life has problems of some kind in some situations. If we take everyones experience with every program you would notice someone has had a problem of some kind with every available program, and when it happens to you I understand it can be disappointing. CIS is not problem free on all systems nothing is, but in general it is a good product.
Now back to the problem if you give a little more backround about your system a simple solution might be available. EG Operating system, other software that may cause any conflicts, non standard DNS settings, any non standard computer settings, type of internet connection or anything else you can think of that could possible affect this problem? I do hope a simple solution is possible for you and I wish you all the very best for this to happen. Kind regards.