Anti-virus scan in Internet Security won't scan properly

I use Comodo Internet Security (free) version 3.9.95478.509, on Windows XP Home Ed. and have lately been encountering problems with anti-virus scanning.

At first, the scanning worked fine until a certain file was reached, then it froze. Now the program won’t show any files being scanned (0}when scanning starts. It just keeps running for hours. After clicking on Stop, I couldn’t close the dialog box, unless I shut down Internet Security altogether. In some cases, the whole system slowed down, I couldn’t get other programs to open quickly, so I turned off the computer, and started it up again.

Other times when I was able to close the anti-virus scan dialog box, I saw an error about insufficient resources when I tried to scan for viruses again (before rebooting).

Should I click on the Diagnostics tool in Miscellaneous? I’d appreciate your help.

yeah click on diagnostics, from what I can tell it is actually sticking in the memory scan. My other XP computer sometimes does that but a restart usually fixes it.

How did you install 3.9? As an upgrade from 3.8 using the program updater or a clean install?

I did that, but the report was that everything works fine. Thanks anyway.

I’m having problems with AV scans getting stuck and killing the machine requiring a reboot, too.

However, how is it acceptable to have an update function in a product, but have it cause serious problems that bring the system to its knees at random times? I’d say if a clean install is required for all new versions, then remove the update function from the product, right?

Also, if I remove CIS and do a clean install, doesn’t that completely wipe the very complicated Defense+ and firewall policies/rules I’ve built up over many months? That’s a huge pain in the neck, isn’t it?

Why can’t Comodo just make the update function work properly? Having to avoid the update function that’s right in the product and do a clean install and ■■■■ away all of one’s complex settings instead… that’s unacceptable.

I am noticing most of the scan issues right now are with XP. Is this actually the case, and which SP is installed?

I also have had the AV crash (not my PC) on me when scanning with XP SP3, with all updates installed.

DB 1265
No other security software installed
DEP on with all CIS prosseces excluded

I have submited my CIS crashdumps to egemen already.

In my case:

Win XP SP3, all critical/security Windows updates applied and current, minimum number of apps (I like simplicity), CIS 3.9.95478.509

Puddingpants, you can export the configuration yuo made under Miscellaneous → Manage My configurations. Put the file in a folder that is not in the CIS installation folder so you don’t run the risk of loosing your configuration when uninstalling.

Oh, there really is an export function for Defense+ and firewall rules? Cool. That’d make an uninstall/reinstall cycle a whole lot easier.

It’s a free product, so I can’t complain too much about it, but I do hope Comodo’s going to fix this problem in the future, so that future updates can be automatically applied like they’re supposed to be.

This reminds me of Firefox (which was called Firebird initially). It too had an “automatic update” function… which never worked right. Users had to ignore it and do an uninstall/reinstall for all new versions that were released.

Eventually the Firefox folks got the auto-update working flawlessly, though. I hope Comodo can, too. Other than the scheduled AV scans freezing, I like the CIS product a lot.

Oh, I excluded all CIS executables I could find from Windows’ DEP. No help; scheduled scans still freeze up and kill the machine. FYI in case that information helps.

Thanks for the info. In the near term, I’m eliminating all scheduled scanning, and will run scans manually each day. In the longer term, when I get time, I will export rules, uninstall CIS, reinstall CIS, then import the rules, and see how that goes.

Remember to run CFP.exe (the GUI) as Admin in order to import/export correctly and error-free.

Running virus scans here on Windows XP sp3 with no issues. Works like a champ. :-TU