Anti-Virus Scan Freezes

Hi all,

I’m running Comodo Internet Security v3.5.57173.439. I’m running XP SP3. For some reason, whenever I try to scan my computer using the anti-virus scan, it freezes at about 30 minutes through. I tried changing the size of the files that it skips and the amount of time before it moves on but no luck. I switched to Comodo a few months ago and I have been occasionally using panda active scan to substitute.

Can anyone provide some help?

Thanks,

E

Hey E & Welcome! :slight_smile:

Can you please post back your Security Software installed.

Cheers,
Josh

Let’s see aside from Comodo Internet Security and memory firewall nothing else. I have executive diskeeper schedule running but no other security software that I know of (or remember). It seems to stop/freeze in D:\Recyclers folder. Not sure if that helps.

I am curious to know if you can empty the Recycle bin and stop and the service of Diskeeper as it may be a possibility of conflict. If that fails, a reinstall may be required. Try those 2 options…

Cheers,
Josh

Thanks for the help. I reinstalled and cleaned out the recycler bin and just finished a scan.

:■■■■

E

I have same (latest) version of CIS. I am running XP SP2; I have tried the uninstall/reinstall a number of times, also emptying recycle bin. This is on 2 desktop PC’s and a Dell D630 laptop.

I have not yet had a virus scan that will complete. It does not matter whether I try to Pause before stopping or not, the virus scan seems to check all the files but does not stop & cannot be terminated. this applies to both installation scans and “normal” scans whether manual or auto initiated.

I have no other security software installed, having completely removed AVG & Zone Alarm and rebooted several times between removal & installation of CIS.

Apart from the scan not quitting the suite works as expected; I did have problems updating Virus databases on all machines, but following re-installation several times, this seems to have been sorted.

I would like to feel :BNC but instead it is more like (:AGY) (:AGY)

What on earth can I do to remedy this scanning situation??

Regards,
Brian

Hello Brian,

Can you see in the scanning status window where it is at the point it “stalls” ?
Maybe there is some specific file that breaks it.

What could be useful to troubleshoot this is sysinternals process monitor.
You can use it to monitor what files cmdagent.exe is accessing that’s the process that does the scanning.

If you don’t know how to use this tool feel free to ask.

I’ll have a read & see if I can work out how to use it.

I doubt it has anything to do with specific files though, over the last couple of attempts, it has locked up at different files on each machine and also different files on the same machine.

Logic would point to it being a software problem as I shouldn’t be getting the same issues on 3 separate computers (on different random files) especially when AVG ran quite happily without locking up on any of them.

regards,
Brian

If you start Procmon it will ask you to “filter” some stuff add the following

Display entries matching these:
-Process name, Is, cmdagent.exe, now click the “Add” button.
Now press OK.

On the top menu bar you have the “registry” icon and the others File,Network, Process, Profiling
Disable all but File.

Now start a scan and see if you can pinpoint where it fails, maybe a specific map or file type etc.

OK, I am saving the Process Monitor results now - the current scan (of critical areas only) has frozen at C:\WINDOWS\System32\drivers\pci.sys.

I will need time to go through Procmon results properly (can’t do it now as I’m off to work)

As before, I can pause the scan - the magnifying glass stops - but stopping does not close the window, it just remains open and won’t go away without a reboot. Processor usage is also maxed out, as is Page File use, even after pausing scan and closing down Procmon.

Regards,
Brian

EDIT: OK, I’ve had a look at the resulting logfile but I can’t make out if/where any problem is. Happy to PM or email the file if it will help but I still maintain this is buggy behaviour. If it can’t be resolved soon I will have to switch providers, I can’t maintain spending 90% of my time re-booting & troubleshooting the whole network.

It’s been a while now with no response; am I to assume there is some work going on behind the scenes, or is too difficult a problem to resolve?

I would just like to know where this is up to,

regards,
Brian

PM received and logfile sent, thanks Ronny.

Cheers,
Brian

Further bit of info, in case it helps…

While ever the scan is still running properly it can be paused then stopped, and it will quit properly. Once it freezes, it can be paused, which will stop the magnifying glass scrolling, but the processor & kernel usage are still maxed out (about 95- 97%), along with high page file use. Stopping doesn’t do anything, the scanning window won’t close and the processor isn’t “released” unless the computer is restarted.

Regards,
Brian

I am extremely disappointed there have been no updates to this issue for a month now, not even a status update on any action under way.

Does anyone have ANY information???

I still have the scan crashing in 3.8.64263.468 with XP64bit.

same problem here
win xp home sp2 x32
CIS only

Can you please post all details needed for a bug report then i can move this post to the bug section so Dev’s can take a look at it. As much “how do you reproduce” it, including if you have a lot of music/movies or other stuff that it’s scanning at the point the processor goes high.

Changed below

[attachment deleted by admin]

Can you please post this info also:
https://forums.comodo.com/bug_report_cis/important_how_to_submit_bugreports_read_this_if_you_want_them_fixed-t26980.0.html

Make sure that this info is placed in all your bug reports even if you join an existing topic to confirm that you are affected too.

* CPU (32 bit or 64 bit)
* Operating System information (including Service Pack Version)
* Actively-running security and utility applications  (Optional if you post a  Comodo Firewall Pro Configuration Report) 
* Specific symptoms of the bug, and steps you can take to reproduce it (step by step).
* Specific steps you have taken to try to resolve it.
* Brief description of your Defense+ and  Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+ (Optional if you post a  Comodo Firewall Pro Configuration Report)
* If you pc reboots or you have a BSOD post in  BSODs: Please add your minidump files here
* Report if you are using an Administrator account Or a Limited User account. Vista users please Report if you have UAC Disabled or Enabled (Optional if you post a  Comodo Firewall Pro Configuration Report)

3.8.64263.468
Xeon 64bit
XP 64bit Service Pack 2
Mozilla, Outlook, and CIS
Scan Crashes and creates windows error report which is attached.
Create any manual scan or any area of the computer
I have added one advanced setting for the firewall allowing remote desktop.
I have to reboot to get CIS to run again.
Administrator account

[attachment deleted by admin]