Another Remote Desktop question

Hi,

Current version CIS (9/1/2012)
I’ve looked through the posts relating to remote desktop being blocked, but haven’t found the answer to my problem yet.

I have a rule to let any mac connect to any mac with incoming TCP on port 3389
I have a rule to let any mac connect to any mac with incoming TCP on port 3389 to svchost
They are above other rules

From another machine on the same network, if I try & start a remote desktop session it fails.
If I disable the Comodo firewall on the machine with the rules above I can connect to it.

What else do I have to set please?

Many thanks,
Paul

Are the allow rules above the deny rules for Application and Global rules?

Are there denied entries in the firewall logfiles during the failed attempts?

Many thanks for looking…

Yes the allow rules are above the deny (I moved them right to the top)
No, annoyingly there are no entries in the firewall logs

Regards,
Paul

Please try the following, go to Firewall → Stealth Ports Wizard and choose option “Define a new trusted network and make my ports stealth for everyone else”.
If you reboot after that procedure see if that helps here.

;D
Many thanks Ronny!

Worked a treat :slight_smile:

Regards,
Paul

It does allow everything on your local network in/out so if your not comfortable with that we have to slowly tighten things up a bit.

It’ll be fine open here, but it would be useful to know how to focus it a bit if you don’t mind taking the time…?

Regards,
Paul

I guess you’ve seen these threads? If so, can you describe in more detail what happens when the connection fails. Are there any log entries on the host pc?