Android App to remote control Winamp needs access to this port

Hi!

First of all, sorry but there was no “new topic” button in the introduce yourself forum so I jumped here.
Also, I did not understand well the three of the forum so I hope this is the right place.
Now the question!
I have downloaded aWARemote, an app for android mobile phones which through wifi should connect to the parent app “aWARemote Server” installed in my notebook, and remotely control Winamp so that I can change songs, volume, etc, wherever I am in the house…
Nice.
But it does not work.
I read comments in the Android Market that it works, so I guess it is a firewall problem.
What I can tell you is that this app asks me to tell the IP address I am using, and to choose a port, and then it should connect to the notebook.
The port it chooses by default is the 8769.
Now, how can I configure the firewall so that that port is available just internally (from my phone to my notebook, but not, for example, from my notebook to internet)?
I mean, I want Comodo to let my phone connect to the notebook through that port, but I fear that the app may use the port for other things so I want to be sure that the app will be allowed just to control Winamp.
Also, should be better to change port instead of using the default one?

:slight_smile:
Thanks!

Welcome :slight_smile:

You’ll need to allow aWARemote Server.exe to receive inbound connection requests. To accomplish this you’ll need a firewall application rule for the process and a firewall global rule for the port.

For the Application rule: Firewall/Network Security Policy/Application Rules

Application Name - aWARemote Server.exe
Action - Allow
Protocol - TCP
Direction - In
Source Address - The IP address of your phone
Destination Address - ANY or the MAC/IP address of this computer
Source Port - ANY
Destination Port - The port used by the server currently 8769

You’ll need to check if the server needs outbound access, when I installed it, it wanted to phone home, I assume to check for updates. It will also need outbound access if Winamp is on a different PC.

For the Global rule: Firewall/Network Security Policy/Global Rules

Action - Allow
Protocol - TCP
Direction - In
Source Address - The IP address of your phone
Destination Address - ANY or the MAC/IP address of this computer
Source Port - ANY
Destination Port - The port used by the server currently 8769

Now, how can I configure the firewall so that that port is available just internally (from my phone to my notebook, but not, for example, from my notebook to internet)?

Specify the source address as your phone only and in the Application rule, block outbound access.

I mean, I want Comodo to let my phone connect to the notebook through that port, but I fear that the app may use the port for other things so I want to be sure that the app will be allowed just to control Winamp.

The remote is actually contacting aWARemote Server.exe, which in turn is controlling Winamp.

Also, should be better to change port instead of using the default one?

Always a good idea.

Thanks!
But it is not working. I surely must have done something wrong.
When I run the app, it says Connection timeout check ip and port settings, then Transport endpoint is not connected, then unable to check server version, ensure that ip and port are correct.

I set all as you said, tcp in, ipv4 (it is the same ip for notebook and phone as they use the same connection) as source address. destination address ( i tried with any and with ip address ,but I do not know how to find the mac address), source port any, dest port (i tried with the original one and with another one).

Also, i wouldn’t know how to "“Specify the source address as your phone only and in the Application rule, block outbound access.”

:slight_smile:

No suggestions?

Just a quick check to see if it is really caused by CIS Firewall.
Temporarily disable the FW, run the phone app and see if it works. Now switch the firewall back to the previous setting (make a note before switching off).

If that fixes the issue, it’s caused by CIS FW configuration, if that doesn’t fix the issue it’s caused by something else.

With firewall off, it works fine. Nice app, I like it, it is what I wanted. Now, I hope I can use it with CIS! :slight_smile:
So, in the app on the phone I can just set the port, and the IP address or Host Name. I tried with both the IP (which actuelly, of course, it is the same for the phone and for the PC, as they share the same connection, with static IP), or with Host Name (which as far as I understand it is the PC name, which I find runnind CMD and then putting ipconfig /all).
In the server (the program installed on the PC) I can configure the port only.
About CIS, I did what Radaghast suggested. As Destination Address I tried both the IP and the MAC, and also the Host Name, but nothing works…

Can you explain how your Phone and PC share the same IP? normally in Wifi this should not be possible.

It might be helpful if you could post precise details of the rules you’ve created, please.

Oh. flip. (may I say flip?).
You are right. I was so sure that all the devices connected to the same router had the same IP.
This is so strange. I played online games once and I was banned because me and my brother were using the same connection even if with two different PC and they were thinking we were a multiaccount because we had the same IP.
So I was sure that devices which share the same connection with a router get a same IP. It is not like that? Can you explain it to me?
Anyway, I saw that my notebook and the phone have got ALMOST the same IP, just the notebook’s one ends with 170, the phone’s one with 171.
Now the rules work perfectly.
I just must see what happens if the IP is not static. I have to change the IP in the rule all the time???
I was able to find the notebook’s mac address which should not change if I am right, but how to find the phone’s mac address???

Finally, I still do not understand what does it mean “Specify the source address as your phone only and in the Application rule, block outbound access.” and how to do that.

Mmm, I did not say flip, I said fuck.
But you know that.
:wink:

A router typically has two interfaces, one interface connects to the Internet and the other to your LAN. The interface that connects to the Internet has a single global IP address, which is the address seen by the outside world. The interface that connects to your LAN uses an address from a special reserved address range, typically 192.168.1.1 Addresses from this range are only viable on a private network and not the Global Internet. Thus:

copmuter 1
192.168.1.2---------
-----192.168.1.1 - Router - Internet address —Internet
computer 2----------/
192.168.1.3

A router typically acts as a DHCP server, which means it can allocate IP addresses to computers on your LAN. The addresses assigned by DHCP are in the same range as the address used on the LAN interface of the router.

191.168.1.x to 192.168.1.254 with a subnet mask of 255.255.255.0

As address 192.168.1.1 is usually assigned to the router, the first address available for a device on the LAN is 192.168.1.2. The numbers may be slightly different in your scenario.

Anyway, I saw that my notebook and the phone have got ALMOST the same IP, just the notebook's one ends with 170, the phone's one with 171. Now the rules work perfectly.

Good to hear :slight_smile:

I just must see what happens if the IP is not static. I have to change the IP in the rule all the time???

You could replace the singe IP address with and address range so that any if the address changes any address from those allocated by DHCP (192.168.1.2 to 192.168.1.254) would still work.

I was able to find the notebook's mac address which should not change if I am right, but how to find the phone's mac address???

Usually something like:

Settings
About Phone
Status
Wi-Fi MAC address

Finally, I still do not understand what does it mean "Specify the source address as your phone only and in the Application rule, block outbound access." and how to do that.

The source address is the IP address assigned to your phone. For the rules:

Application Name - aWARemote Server.exe
Action - Allow
Protocol - TCP
Direction - In
Source Address - The IP address of your phone (The source address of your phone)
Destination Address - ANY or the MAC/IP address of this computer
Source Port - ANY
Destination Port - The port used by the server currently 8769

Application Name - aWARemote Server.exe
Action - Block
Protocol - IP
Direction - Out
Source Address - Any
Destination Address - Any
IP Details - Any

Hi, I kind of am late with my reply :slight_smile:
I am not sure what happened, I may have never received the notification of your reply or forgot to reply back, but as I now see it, and I hate when people help somebody and this somebody does not even thank, I wanted at least to thank you for the help :wink:

I finally stopped using Winamp. So, problem solved :smiley:
My favourite player is now Foobar.

Cheers