An unsupported operation was attempted.

Hey all,

I’m trying to install Comodo v3 but I get this error at the beginning. I don’t know why it does that because I have used Comodo before and never had this problem.

I have Windows Vista Ultimate SP1 64-bit

Can someone help me please?


Hello Unit and Welcome to the forums :slight_smile:

So when you first ever installed CPF3 it worked fine?

You will have to fully uninstall the previous version, There are guides on this Forum site.

This has to be a bug because alot of users have reported this, Especially under Vista.


In my view i think it’s that he still has traces of CPF3 on his Pc,

Because it worked the first install. I know that after doing a messy uninstall on my own pc that I couldn’t install a newer version after deleting the entries in the registry it worked fine for me.

I have some LEGACY entries in the registry that were left over by the previous installation. I can’t find a way to get rid of them though because they keep coming back when I delete them.

I have exactly the same problem and you know what i will do ? I will not use Commodo Firewall on this PC, because I’m not the kind of user that tries to search the needle in the sand.
This error message doesn’t help at all so i’m searching for an alternative, sadly.

Windows XP Pro X64 SP2

Try Revo uninstaller for all of your uninstall processes it works good and also deletes the remaning keys left over. and dose a very good job indeed.

The Revo uninstaller website says 64bit Vista is not supported.

Also, I just installed fresh Vista 64bit and comodo won’t install for me: gives “an unsupported operation was attempted”.

If others have done it successfully (?) then I suppose that means some of the other software I installed is in conflict.

Welcome to the forum bric :slight_smile:
Are you certain that you download the correct version (x64) please check.
Thank you

Hello all I just install XP 64 read how awesome a firewall this one was… downloaded CIS_Setup_3.5.54375.427_XP_Vista_x64
and I get the exact same error “An Unsupported operation was attemped”
Like to try out this fine sounding firewall… I’m using windows xp 64 sp2
It’s a Q9550 cpu if that matters.

Hi Gerhardus

Welcome to the Comodo Forum

There has been reported corrupted file downloads on X64 version of CIS. Please read over this thread and download again from the given link.;msg217455#msg217455


The file size was the same as I had previously downloaded, but I did re-download from the provided link (my original download was right off the Comodo website)… Still have the same error.

I have the same problem with winxp x64 sp2, and the problem is not the comodo .exe file. I cant install comodo

I’ll keep checking for new version daily… So far no luck. If there’s a Beta i’d love to try it. Beta tested other stuff in the past.