Am having problems updating AV signatures to more then 30%...

I installed CIS_Setup_3.11.108364.552_XP_Vista_x32.exe. There has been a previous version
but on update I had to delete it acc to the program and I did but then got stuck as signatures donot want for update to go above 30% which means the AV will not work… I never had problems before with comodo at least not something which should be simple!! Its a good motherboard (ASUS), a celeron processor and 2 gb of DDR2. Drives are 1tb Seagate and 300 (about) gb Seagate. I would appreciate some advice!
Do you have a product which I can use and then check my system??? Its rather frustrating as I installed a system on Saturday and like all the others before it , no problems. Obviously this one is my own!!!

HI tracer, The first update of CIS AV is a huge one (appx. 100 mb). During the first update, hence, the progress stucks at 30%. (This may give the user a confusion, whether it is being updated or not and whether computer has hanged etc.) Give CIS sometime to update. Once this is updated, the daily updates are smaller ones.

Hello 0tracer,

See the FAQ Database updates freeze at 30% what’s going on

Ok, I had kept it running overnight and in the morning it was more or less finished.
System isn’t quite upto scratch though and I suspect that previous things I did caused some damage!
It now takes ages to boot and then I have problems starting some programs. I suspect that another comodo program messed something up in the registry… (The one to clean the registry).
I am tracking it down but its useful to know that upgrading can take HOURS.
I never saw that before as I am on ADSL!

Did you create a backup of those changes ?

Hi,
I am running CIS 3.11.
Also facing the 30% update problem.
I can see cmdagent downloading the update.
But it never reaches anywhere near 10MB and the update automatically cuts off.
Several attempts later and atill the same behaviour, no luck. :cry:

Isn’t there anywhere on the Comodo website where we can download the HUGE initial database using download accelerators ? Why is the initial database so large ? ???

Help, anyone ?

Thanks a lot.

These are questions that have been asked for a long time. They are working on reducing the database size, but why they do not have a location to simply download the virus database as other AV solutions do is anybodies guess.

All I can suggest and it worked in my case, is to run the ■■■■■■ download for a long time, took I think less then 24 hours for me but it might have been 30 running as only thing besides OS. (XP).
I had a few days off and I left computer running, switched on, and it was finished when I came back…
This should not be necessary in my opinion, If anyone had paid for a product doing the same thing it would get bounced out…

Note I have no idea if database is anywhere on my system but if I know whats called I can transmit it somewhere in a torrent… And also note it would be encrypted/compacted WITH PASSWORD.

I wonder anyway why the database is so big. Lousy programming??

Hi people,
Last night, it took several hours to download 100MB++ of something.
Then the download suddenly cut off.#@!
I was about to give up on Comodo.

Today, I switched on my PC, and it began downloading again.
I took a look, the download is working now; it went past 30% mark
I checked the CIS version.
It was 3.11 the night before, but it’s 3.12 now.
And the AV update completed in a jiffy and everything is well now. :-TU
I went over to the CIS download site.
It’s still 3.11 over there.
I think Comodo’s working on it …

FYI.

The forums always get the new versions first. It can be found here: https://forums.comodo.com/feedbackcommentsannouncementsnews_cis/comodo_internet_security_312111745560_released-t45362.0.html .

Hello all,

This weekend I updated from CIS 3.11 to 3.12 and have spent hours trying to update the Virus Signature Database with no success.

As many other users have described the update progress bar stalls at 30 %.

I went into the firewall’s active connections and the “Bytes In” usually stop at around 7.4 MB the most being 9.5 MB, then the connection is dropped and soon after the I get the attached “Update Failed” message.

Since one of the posts above mentioned the download having recommencing the next morning, I insisted and manually started the download 17 times in the hope that since the file was so large there would have been some configuration in the downloader for it to pick up where it had left off. Since I dowloaded over 132 MB and the CIS summary screen still reads "Never Updated"It seems like in my attempts I downloaded trhe same thing 17 times.

When cmdagent starts the download automatically it also stalls at around 7.5 MB.

Frustrating to say the least.

Hopefully with all the reposts of this not working - and some of them I saw dating back to July, someone is doing something to solve this problem.

Any help is appreciated, IMHO the least to be done is to:

  1. Provide a downloadable .CAV file on Comodo website to allow for download managers to assist with such a large download. (Omelet Guy did so but that was for version 3.11 and from his reply to my inquiry, that database may not be compatible with Version 3.12.)

  2. Alter the Comodo Downloader to pick up where the previous attempt failed.

  3. Provide the latest version with most of the current signature database in the same download so such extensive downloads do not have to be made later.

  4. Provide a more useful Download Progress report box showing if connection to server is active and the actual download percentage vs. total (i.e. 7.4 MB of 108 MB = 6.85 % )

Further info on my systems:

  1. XP Pro SP3 / 512 MB RAM / Sempron

although the same behavior was seen in laptop running

  1. Vista Home Premium / 3GB Ram / Core Duo.

The same behavior in 2 such different systems leads me to suspect the problem may be between the Comodo server and my 3G Internet connection (PPP) through a HUAWEI E156B thumb drive modem.

At least one other user I saw over the weekend had update problems using 3G.

Any help is greatly appreciated!

Thanks

[attachment deleted by admin]

Hi db.distler,

Without having a network packet trace it’s hard to say but probably the download(s) timed out or could be reset on the server-side because of what ever issue arose on the network.

Most of these issue’s i have seen are related to underlying network issues.

I agree that it would be very nice especially for users with lower bandwidth to have a separate AV update link that can be downloaded with or without a download manager…

But that’s up to Comodo to decide.

Ronny,

Thanks for your reply. I really want to get to the bottom of this but I have very little knowledge of WAN network mechanics. Here’s a report I was able to get which I think may answer your question:

This trace was started on 30/09/2009 21:41:55. The host ‘91.212.12.69’ (known as mpdown1.mcr.colo.comodo.com) has been found, and is reachable in 20 hops. Also, it responded to HTTP requests on port 80 (it is running server nginx/0.6.39, which responded in 2281ms). The TTL value of packets received from it is 49. In general, hops in this route respond slowly (over 238ms on average). All hops after hop 7 in network ‘Telefonica International Wholesale Network’ respond particularly slowly. The DNS lookup was completed almost instantaneously (less than 2ms - this may be the result of caching).

If it does, please guide me as to what I should do next.

If not, please give me a clue on what other info I should look for.

Thanks!

I’m not sure what tool you used but based on this information there is a really really high latency on your connection to the download servers 2281ms !!

Can you try the following, open a command-box and type:

ping download.comodo.com
ping eu1.download.comodo.com

And post the responses here, I’m wondering what the roundtrip times are for those on your connection.

Hello Ronny

Here’s what I got:

Pinging download.comodo.com [91.199.212.171] with 32 bytes of data:
Reply from 91.199.212.171: bytes=32 time=503ms TTL=49
Reply from 91.199.212.171: bytes=32 time=463ms TTL=48
Reply from 91.199.212.171: bytes=32 time=452ms TTL=49
Request timed out.

Ping statistics for 91.199.212.171:
Packets sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 452ms, Maximum = 503ms, Average = 472ms

Pinging eu1.download.comodo.com [149.5.128.69] with 32 bytes of data:
Reply from 149.5.128.69: bytes=32 time=1938ms TTL=47
Reply from 149.5.128.69: bytes=32 time=619ms TTL=46
Reply from 149.5.128.69: bytes=32 time=478ms TTL=46
Reply from 149.5.128.69: bytes=32 time=477ms TTL=47

Ping statistics for 149.5.128.69:
Packets sent = 4, Received = 3, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 477ms, Maximum = 1938ms, Average = 878ms

Thanks!

How’s your signal strength for the G3 ? it looks like your having a really slow connection with packet loss…
This could cause trouble on a large AV db download…

Pinging download.comodo.com [91.199.212.171] with 32 bytes of data: Reply from 91.199.212.171: bytes=32 time=503ms TTL=49 Reply from 91.199.212.171: bytes=32 time=463ms TTL=48 Reply from 91.199.212.171: bytes=32 time=452ms TTL=49 [b]Request timed out.[/b]

Ping statistics for 91.199.212.171:
Packets sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 452ms, Maximum = 503ms, Average = 472ms

can you repeat the ping commands with -n 100 like:

ping -n 100 download.comodo.com

this will send 100 pings and can you post the “Ping statistics” again ?

OK here we go…

Ping Statistics for 91.199.212.171:
Packets: Sent = 100, Received = 99, Lost = 1 (1% loss),
Approximate round trip times in milli-seconds:
Minimum = 298ms, Maximum = 1422ms, Average 493ms

Of these 5 were over 1 second

Just a question if, in fact, Comodo’s server cuts off the download due to a lost packet, why does that almost always seem to happen around 7.4 MB?

I repeated the ping command and the second time there were 2 timed out requests and the 1st request that timed out was half way down the list whereas in the 1st ping series it was the 15th.

Would this have anything to do with the cut off at 7.4 MB?

Is 1 or 2% loss that bad?

Thanks

Well “under the hood” TCP has a mechanism to try and keep to recover packets loss and slow connections.
It can tell the sending host to slow down, send less bytes in a frame, tell it hasn’t received certain packets so it will take some time to use all these tricks to see if it can handle the traffic. So that could result in having it break around the same time.

It’s hard to tell without a real packet capture what’s going on.

An other issue is also the fact that it has to download a number of single files that will cause some overhead because after each file this handshaking etc has to start all over again…

Are you willing to create a packet capture of the download with wireshark, you can find it here

I am adding more to this post:

Today I downloaded CIS and installed it on other computer( Win Xp Sp2) while updating virus database it remained at 30% . I checked download in firewall section they were 79MB appx. I tried to update it thrice each subsequent download was of the order of 30-35 MB.

I have read the FAQ on CIS.

Preveous post in this thread suggest a download of the order of 100MB( I have downloded more)

Carried ping(100 times) result are Packet sent 100 recived 100 appx round trip time
Min 306ms Max 316 avg 311ms

help will be apprciated.

regards

Adi

Please try this,

Download the latest full AV database version here:
http://download.comodo.com/av/updates311/sigs/bases/BASE_END_USER_v2456.cav

save this file on disk, reboot in safe-mode and replace c:\program files\comodo\comodo internet security\scanners\bases.cav with this version and make sure you rename it to bases.cav

Now reboot in normal mode CIS will still complain it never updates, just click on it to update the latest incremental updates also and you should be good to go.