Always on top BUG +work arround

(Bug just to be informed, work around also added to topic)

Running current version of Comodo Firewall (3.10.102363.531)
Release Date: July 7, 2009
On windows 7 64bit (RC1 MSDN Release)

It seems that at the moment I run a fullscreen application. Which is not allowed jet to use resources.
The popup to give these permissions does not go on top.

Therefore I can never let it to be allowed to use system resources, and the application will never start.
It is not possible to use, CRTL-ALT-DEL or ALT-TAB to go out of “blank full screen”. (system looks to be looked up. but its a deadlock situation) The only solution is to use a hard reset.

When i manually configure the application to have these permission the application runs normally.

PS I know Windows 7 may not be supported right now, its just to inform users how might use this Comodo version on Windows 7 and experiencing the same problem

Another way to go with full screen applications is to put the firewall and D+ in training mode before running the application. In this mode CIS will learn rules without alerting. After a few minutes shut down the application and put CIS back to its previous settings.