always error on start-up, diagnosics "did not find any errors"

Using Comodo Firewall on Windows 7 32 bit

I have a problem with Comodo Firewall that on every startup, it will give the following error

COMODO Security Agent could not be started. Would you like to run the diagnostics tool to fix this error

I run the diagnostics and always get

Diagnostics did not find any errors

I can attempt to run the firewall as many times as I like without running diagnostics, it will always result in the ‘could not be started’ error

and until I have actually ran diagnostics, it WON’T start up, and until Comodo Firewall is up and running, my internet connection DOES NOT work, like if Comodo Firewall is blocking ALL access to the internet until it is working.

this problem occurs on ALL Windows start-up attempts!! I also have Kaspersky Internet Secuity 2013 as my one and only AnitVirus as I figured out by other threads that you guys need to know. it is the ONLY AntiVirus I ever had

how do I fix these errors and get Comodo working??

I fixed the quote structure. Eric

Please try reinstalling CIS following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable clean starting point.

I tried that. took me awhile to do so, but the same problem exists on a clean install! and on top of that, my settings I exported DO NOT import under the new installation!!! it says it was successful at importing, but NONE of my settings or application rules are there!!!

what do I do next??

When importing you need to give a name to the profile you are importing. It is best to give a name that is different like f.e. Internet Security Imported. That way you won’t overwrite an existing profile. You will have to activate the imported profile.

When you say you have KIS installed. Do you mean you have installed the complete suite with network firewall, hips or other proactive protection and the AV?

Why do all moderators offer up the standard answer of reinstalling and to this date there has not been not one solution to the problem.
I am plagued with the same issues and there are no solutions to the many other people with this same problem? For me the this problem just cropped up after an install of a new video card.
I am not running any other AV software and have been happy with Comodo up to this point.

With big changes to a system like changing a video card it is best to not only uninstall the old graphics drivers but also let Driver Sweeper remove possible left overs by the uninstaller.

See if that does the trick for you.

With big changes like updating to a service pack sometimes CIS needs to be reinstalled. Things sometimes get rubbed the wrong way at a deep level in the OS and then a reinstall of CIS is a thing to try. It happened for part of the users when updating from Windows 8.0 to 8.1 f.e… I can’t make things more beautiful than they are.

Well Thanks for the reply and I did try your suggestion.
I uninstalled Comodo and did a cleanup tool and registry cleaner as well to remove all instances of Comodo.
I removed all display drivers using the tool suggested that was replaced with Display Driver Uninstaller.
I then reinstalled Comodo with a new installer and it failed with the same Security Agent not starting error.
I uninstalled that, cleanup tool again and registry cleaner again and then tried an older Comodo installer from December 2014 I still had and that failed as well.
I am at the point of going to another antivirus program as this has just stumped me.
I am open to more ideas before I switch, because I have enjoyed using Comodo for the last 5 years and have a certain level of comfort with it.

What EricJH said is correct. Software variables can wreck a proper install much less hardware changes. I’ve made and will release a new updated removal tool this week to mouse1 or another Mod for review.

Further to my reply yesterday, I thought this might be a useful clue as well. Every time I go thru the install process, it wipes out my home page on internet explorer and sets it to a blank page.

It also chokes off my internet connection at start up until I have ran the diagnostics for security agent. Something to do with the dns server not responding I believe as one of the times after I uninstalled Comodo, I needed to do “netsh winsock reset” from command line as seen here:

Not sure if this helps.

If the problem is with DNS servers make sure to set Windows to obtain DNS server addresses automatically. You can follow this procedure but instead of setting Secure DNS servers set Windows to automatically obtain DNS server addresses.

Does changing DNS servers fix the problem or does the problem with security agent persist?

Did you in the process of uninstalling CIS remove possible left overs of previously installed security programs?

Yes I did remove all residuals of Comodo using the tool.
As for DNS specifically, changing the DNS did not fix the problem necessarily but rather the netsh procedure I mentioned.
I am still getting the start up error. When I run diagnostics and the start Comodo, all is fine.

@EricJH, any other ideas?

When doing the clean install did you also use clean up tools for previously installed other security programs? Can you tell me what other security programs you have installed and whether they run in the background with CIS or are on demand only?

Sorry, but I had given up on using Comodo because of this issue.

As for cleanup on AV programs, the only programs I have used were Comodo and Microsoft Security Essentials. I have always found that these programs work well together. Currently I am still just using Microsoft Security Essentials.

I continually cleanup my system on a regular basis.

I would like to try and reinstall Comodo soon, but just waiting until I have time to fiddle with it IF I do reinstall.

So far status quo is “If it isn’t broken, don’t fix it”.

Hi I share your frustration and for months I have one desktop computer with your exact symptoms…diagnostics start but no result but reading your latest I wonder if you lose your network connection like I do for that one troublesome computer…did u at any time try installing via Comodo dns? That seems to to the only thing I haven’t tried. I HAVE CIS on many machines work home and friends just can’t believe we can’t get a sensible response