Allowing "in" connection to Apache with "remember" results in allowing All IPs

I have Apache (www server) installed on Vista. When there is an incoming connection from Internet from a web-browser (port www) I give “Allow” +“Remember”. This results in Commodo adding a rule for Apache (an application): “Allow Ip In From Ip Any To …”. This not what I expect as I want to allow only that particular Ip which was connecting. Currently I am training with Apache and I know in advance when someone is to connect so I can allow, but not want to allow all Internet at once! Is it normal behaviour of a firewall to allow all ip when adding a rule for a given Ip? How can I force comodo to work how I expect it to work? Maybe there is an option which I should turn on but I can’t find it.
My comodo is “free” version 3.5 (up to date). OS is Vista Home Premium 32-bit. Defense+ is diabled.

Hi Ravenik, welcome to the forums.

Open CIS/CFP - Firewall - Advanced button - Firewall Behavior Settings - Alert Settings tab. By default (Medium setting) the firewall alerts & generate rules for incoming/outgoing connections & the protocol. To include ports as well, move the slider to High. Very High would also include IPs. I hope that helps.

Now after applying “Very High” to “Alert Settings” it works perfectly. Thanks for support.

Very High? You want Apache (and everything else) to prompt you for every different IP address?