Allowing a Home Network

What settings do I use to unblock a PC for file, print and net sharing? Is it safe to unblock all connections for the one IP


The easiest approach to this, is to create a new Zone/Trusted Network. Doing so will allow free flow of information between PCs on your LAN.


  1. Security/Tasks/Add/Remove/Modify a Zone
  2. Give the Zone a name - something meaningful)
  3. Define a range of addresses for your LAN (for example: -
  4. Ok
  5. Security/Tasks/Define a New Trusted Network
  6. Next
  7. Select the Zone name you created in step 2
  8. Next

This will create two new rules in Network Monitor, the should be right at the top, positions 0 and 1

Hopefully, having done that, you will be able to see all the PCs on your LAN


Nearly works. Local stuff works. The internet does not. What do I need to change?

Set IP on other PC to
All range matches this

When you say “The Internet does not” what exactly do you mean?

Access to shared folders is fine, but there is no connection for the internet on the non-gateway PC

Have you configured ICS (Internet Connection Sharing) Also, is the Windows firewall disabled?

yes and yes

Ok. Would you provide me with complete details of the configuration of each PC please

There are two PCs, joined via a crossover cable. Should I set the IP to automatic, or should I choose an IP for each PC. Before when I set the boundaries I set an IP on the Non-gateway PC. I set the both the boundaries to match the IP on each machine (eg start and end on on the gateway). Internet connection works via wireless router. There is internet access on the gateway, but the oher machine can only get internet access when the gateway sets Comodo to allow all.

Hi Buggy.

I’m a little confused, are you using XP? If so, when you configure ICS, it automatically assigns as the IP Address on the ‘gateway’ machine and then acts as a DHCP server for the clients on the LAN. You shouldn’t need to manually assign IP Addresses.

That aside, The fact that you can access the Internet from the client when you set CFP to Allow All, suggests a rules issue or perhaps a Block rule in the firewall. It would probably be a good idea to review the CFP log files, to see if your browser is being blocked.