Allowing a blocked connection

Downloaded the latest CIS. I set firewall to training mode and needed alerts for connections.

Network setup: Broadband router, with auto DHCP. 3+ devices are connected via wifi. Two devices that are always meant to connect to each other are assigned DHCP static address at 101 (smartphone) and 102 (pc) through the router. Router is set with Firewall, no SPI, no port forwarding. This is always connected to the internet. All components mentioned here are within 4 steps of walking radius. Wifi bar is always full.

PC runs on win8.1 pro 64bit. Android version is 4.2.1

Application setup: Two android apps and respective PC apps are used.

(A) AirStream (for streaming PC stored video files and maybe some music) . PC suite version is installed too.
Airstream port at 8082 or 8083 (no clue on further details as this is the only port number that shows up in the setting).
Connection method is when user name and password is logged in from pc first and then smartphone.

(B) Winput (for controlling PC’s mouse and keyboard). PC suite version is installed too.
Winput’s TCP is 8655 and UDP is 8755.
Connection is through PC first starting up the ports, then smartphone would connect to ports and take control whenever needed.

Problem history: The two above apps always disconnect after a while of use and never connects back again. Restarting the PC or phone does not always work to restore the connection (most of the time). Changed default Windows Firewall rule to accept TCP or UDP - all ports and specific ports were edited - and still disconnection occurs after a while and never connects back. Changed to ZoneAlaram which worked for a while and again disconnected. Now changed to Comodo CIS. Android version of Microsoft RDP has no issues at all.

When CIS got installed and restarted. The connection was fine. Then the app got disconnected again. Added the two PC versions of the app suite with Application Rules. Now Saw that when I try to connect from the smartphone, the firewall will show a count of 1 inbound that its blocked. How do I know that [an entry is] blocked entry and enabled to allow that connection?

Got the second (B) Winput app to work constantly. After adding the local LAN ip range under Network Zones, its working like its supposed to. Its connecting instantly after closing and opening the android app (unlike before which was a hurdle). Its connecting on demand.

The first mentioned app (A) Airstream is yet to be solved. The Firewall event log gives this information about being blocked from source to destination. The destination ports are added in Portsets. I’m not clear how the application rule should be. At the moment - All ip in and out & All tcp in and out for port 8082/3

Where am I going wrong with this connection rule?

[attachment deleted by admin]

Someone please help.

I have used Comodo firewall 10 yrs ago and knew less about network jargon. It was an complicated affair to use the application then. I have improved over time. Other alternatives that I used more from being simple to use to no proper user control.

This version of Comodo got me using it immediately. Wish I could get a heads up on what rule I should use to overcome the block seen in the firewall log event. Please see the attachment in the previous post.

Thank you.

Pc runs on win8.1pro 64bit and android is 4.2.1

Try creating an application rule for the “Windows Operating System”

Ex: Allow, TCP, IN, and then the ip of your device.

Also you can try to stealth ports:

“Alert Incoming connections” and see if that helps

Thanks for replying.

Made the application rule labeled Windows operating system and no change in receiving connection. The firewall log has not modified though log trigger was checked.

Alert Incoming connections does not prompt any pop up windows either.

To add to the development, the app what was working is not connecting anymore. Back to square one.

Should uninstall and reinstall address understanding what is wrong? So confused that it can be so hard to get two devices to talk over fixed ip address and port numbers.

In a few minutes changes started showing up. The Winput app is working again.

As for the second app, the firewall log is showing that “Win OS” application rule is still blocked. It has TCP in and out from to 102 for any port number. Added a global rule with same rules too. No connection as of yet. This particular connection is getting blocked.