Allow VirtualBox guests act as server

I’d like to allow some virtual machines running in VirtualBox to act as server.
They are using “bridged networking”, via a wireless interface on my notebook. The host OS is a Windows 7 64 bit.
As far as I remember, the older versions of CIS firewall allowed this by default (I’m not sure)
Now I’m using CIS Firewall 8.2.0 and it blocks all incoming traffic.
Do you have any idea, how can I allow all virtualbox guests to work as servers?
(I found a similar question on virtualbox forum, but the only answer was that try at here…)

I’ve tried to set a custom rule for running process VirtualBox.exe, VBoxSVC.exe then the file VirtualBox.exe to allow traffic in and out (IP/icmp/TCP or UDP), but it has no effect…

Update: I need to modify my question… How can I allow any program to act as a server?? I’ve tried to run a little web server, written in python (using ActiveState Python 2.7 from cmd.exe: python -m SimpleHTTPServer 8888). I can’t connect to that too, though I allowed all IP traffic (in and out) to python.exe and cmd.exe… I gave up. :frowning: (do I need to replace CIS to another firewall software?)
- It was my fault…

But… currently I can access one of my Virtualbox guest, for example as http server, but I can’t ping it… tcpdump shows all incoming packet, except icmp echo requests… Why? I don’t understand…

Update… the 2nd… I can’t access virtual machines again. The only thing I found is the log entries about blocked attempts in CIS Firewall log. In the column “Application” I see: “Windows Operating System”… :frowning:

Make sure you have global rules that allow incoming connections to the destination MAC address of the virtual machine guest network adapter.

I don’t understand this… :frowning:
Yesterday I uninstalled both Virtualbox, and CIS, then reinstalled CIS, and installed Virtualbox 4.3 instead of 5.0.
Since I’ve downgraded Virtualbox 5.x to the version 4.3.30, I can access my virtual machines from other machines. I can ping, I can access virtualized web servers etc. CIS is now running with default “COMODO Internet Security” settings.
The only thing which doesn’t want to work, is a simple web server on the host, written in python. (host is a win7, I’m using ActiveState Python on it.)
I allowed all IP traffic (in and out) for C:\Python27\python.exe, then I start the web server: C:\Python27\python -m SimpleHTTPServer, but I can’t access it from other machines. CIS block all attempts, and in the Application column of log, I see the Operating System…
(I’ve tried it in Safe mode, and with Custom rules, the results are the same)
Yesterday it was working for a short time… :-\