Allow another computer on the same wireless connection through RPD

I have two computers (A and B) connected to a wireless router and I’d like to connect from A to B using remote desktop connection. I’ve added Network->Global Rules as “accept anything from ” to computer B but RDP connection still fails. I can connect fine if I disable Comodo firewall on B. What should I do?

Both are using Windows 7 and computer B uses Comodo Firewall 5.5

See if - Personal Firewall Is Blocking Remote Access - helps