"Allow" and "Always trust this file" does not stick

I am getting warning messages about programs on my system, I click on the “Allow” and “Always trust this program” answer but Comodo keeps asking me the next time I use these programs.

I have used these programs without trouble until the latest upgrade of Comodo firewall.

Any suggestions?



Yes can confirm, some apps don’t make it through and are not remebered by the firewall
even if clicking allow all the time, there must be a bug in there. Please fix it as the firewall is unusable.

Best regards.

P.S.: is the previous version downloadable?

For the Debug Crew a test case:

App1 on HOST1\folder
App2 on HOST2\folder\

execute App1
App1 calls \Host2\folder\App2
Popup Allow Deny?
Click Allow -------------> nothing happens, popup keeps showing up again till the app is killed

Workaround: Settings->secure files → add
choose current processes
app is listed there as \host2\folder\App2
select and ok

the funny thing is that even if being added as \host2\folder\app2
next you open the list it will show up as mapped_drive\folder\app2

First question. Are these programs on an external drive of some sort: USB driver, NAS, on an encrypted partition/drive? Then it won’t remember after ending a Windows session (reboot).

When the programs are not on an external drive can you tell what programs are affected.

Tx. Please start your own topic about this. When you are certain the described scenario worked on v4 then it looks like you found a bug. Plrease file a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Also follow How to determine which file is causing a manual scan to hang to determine what file was causing the scanner to be hung. Please add this information to your bug report.

Thanks for your help Eric.

  1. The program is on the main drive, no USB or external drive or encrypted drive. Also it gives the dialogue box “Splash pro could not be recognised” every time I try to open it not just between reboots.

  2. The program is a video player which worked fine under v4.

  3. I will fill out a bug report.



And it’s still happening…

Been meaning to say this for a few days now, sorry…

SOLVED! Latest update fixed it. All is working well again.