All modules disabled after installing - despite uninstalling antivirus, etc

Have installed latest version of firewall (2.4) but am unable to get it to work. After initialising it comes up with 3 pop ups saying each of the modules has not installed, and I find I cannot turn any of them on, and I have basically the shell of a firewall, but nothing works. I found one other similar topic on here - but that was no help at all as no solution was posted, theirs just magically resolved itself

Following comments read on similar issues on here, I have removed the previous firewall (which I’m regretting now!), removed prevx, removed my antivirus, removed windows defender. I have cleaned the registry with registry mechanic & another one. And I have now rebooted about 15 times.

Please does someone, anyone, know of a solution to this, as the only thing I can think of now is that I have no choice but to abandon comodo & install a user friendly firewall

PS. I’m using windows xp sp2 home edition

Welcome Fedup.

Sorry to hear you have had so much trouble. I’m guessing that one of the other programs that you mentioned is not dead yet. Your description sounds like what has been happening to ZA users when they try and uninstall that firewall. If I might ask, which firewall were you using before?


yes it was zone alarm - though I cant find any trace of it left - and have run 2 different cleanup programs several times now

Have you tried to install any other brands of firewalls to see if they install alright, besides ZA?

I know this is drastic, but, have you thought about reinstalling Windows? Starting with a clean OS might be the way to get rid of all of the stuff that is causing the problem.

I like ZA personally but boy it has caused a lot of headaches for people when they have tried to uninstall it. I haven’t really seen too many problems posted with Prevx or even Windows Defender.

Don’t give up as someone here possibly has a better solution.


cheers jasper - I had prevx & windows defender on before & not had any problems getting anything else to work with zone alarm, it just seems to be comodo that throws a tantrum! It would cause me too many problems & lose me too much stuff to consider a reinstall. So I guess, if there’s no solution to this, no way to get comodo to actually work, I’ll have to go back to zone alarm.

my brother now tells me he had the same problem with comodo & uninstalled it, so I guess thats the only solution

Zonealarm can be a big problem to fully remove:

Once logged on as your Administrator profile, open a My Computer window and select Tools → Folder Options → View tab to make sure you can view hidden files and folders. Click OK. Now search your C drive for the following terms, deleting any files or folders that match: zonelabs, 'zone labs’ and 'Internet logs’.

Then locate and delete the following files, all of which will be found somewhere in your Windows folder: vsconfig.xml, vsdata.dll, vsdata95.vxd, vsdatant.sys, vsmon., vsmonapi.dll, vsnetutils.dll, vspubapi.dll, zaplus., zapro.*, zlparser.dll, zonealarm.exe, and zoneband.dll. Also find vsutil.dll, right-click it and select Properties → Version tab; if it’s a Zonelabs file, delete it too. Next, search for and delete any files or folders with zapro, zonealarm and 'zonealarm pro’. Finally, empty your Recycle bin and restart Windows.

Run RegCleaner and then try installing CPF again.


As an afterthought, if you have spybot or some other program that allows to view and control startup programs check the start up list to see if any zona alarm files are still starting up with windows. Alternatively you could look using msconfig.

Before trying to get rid of ZA make sure none of the files are starting up with windows first.

You may even be better removing CPF, re-installing ZA, unchecking the box that tells ZA to start with windows,reboot and then try uninstalling ZA again. Check for files as in my last post and then try installing CPF again.

Believe me CPF is so much better than ZA that it will be worth the effort.


Did you shutdown ZoneAlarm and reboot before uninstalling? There are several steps, a couple reboots, and additional registry cleaning to uninstall ZoneAlarm correctly and completely.

Here’s a link to the instructions on Check Point’s forum:

Perhaps reinstall ZoneAlarm and then uninstall following the instructions.

cheers guys, will work through that & let you know the result!!

Good day! (:WAV) This is for fedup! I had what I believe is the same problem after installing CPF…may I ask if you have tried uninstalling and then reinstalling CPF since your first install.
I made the mistake of not shutting down Boclean, AVG Antivirus, and ProcessGuard, when I installed CPF, and this apparently was causing the problem of the greyed-out monitor buttons and nothing working. To remedy the problem, I simply shut them all down, uninstalled CPF, rebooted, shut the security programs down again, and reinstalled CPF…rebooted once more and everything was working when Windows restarted.
I hope this might help someone else
Good luck, Mele (:WIN)

If I had any hair - I would definitely pulled it out by now (:AGY) (:AGY) (:AGY)

Thanks for your responses guys, but having done all of the above now, and comodo still refuses to work - I guess its time to accept that comodo doesnt like me & isnt going to let me play with their toys!!

I have spent most of the last 30 hours trying to get this firewall to install - installing & uninstalling various programs, using 3 different clean up programs, searching for & deleting files, reinstalling ZA & then following the recommended uninstall process, cleaning the registry, swearing at the pc, screaming & banging on my pc desk (:AGY) all to no avail

I guess its time to admit defeat & go back to zone alarm

Sorry to see you’re having a difficult time with this. It’s understandable that you dont want to continue the reinstallation routine. However, if you’re willing to return in the future, perhaps by the next version it will have it fixed as I’m certain you’re not the only one with this problem.

Related threads:,5653.0.html,5960.0.html,6399.0.html,6739.0.html,6859.0.html,7034.0.html,7186.0.html,7216.0.html,7246.0.html

Some affected users have filed tickets on this, which means the official team is informed about this already.

cheers soya - have just filed one myself now too

Great! The more tickets, the higher chance so that they will narrow down the issue. I know this issue when manifested by a log off/on is actually resolved in v3, but your issue is the other one when CFP starts off like this on a boot, so it could be a bit different.